{"answers":{"affected":"2 open source packages ship an affected version, including node-ipc.","exploited":"There is no known exploitation of GHSA-3mpp-xfvh-qh37 in the wild and no public exploit code.","fix":"Upgrade node-ipc to 12.0.0 or later.","what":"GHSA-3mpp-xfvh-qh37 is a vulnerability in node-ipc, published on 16 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3mpp-xfvh-qh37 and fix it if it is affected.\n\nWhat it is: GHSA-3mpp-xfvh-qh37 is a vulnerability in node-ipc, published on 16 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3mpp-xfvh-qh37 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-ipc (npm): affected from 11.0.0; fixed in 12.0.0\n- node-ipc (npm): affected from 11.0.0; fixed in 12.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3mpp-xfvh-qh37/ (Markdown: https://insights.sbomify.com/GHSA-3mpp-xfvh-qh37/index.md)","id":"GHSA-3mpp-xfvh-qh37","markdown":"https://insights.sbomify.com/GHSA-3mpp-xfvh-qh37/index.md","name":"GHSA-3mpp-xfvh-qh37","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js IPC library","requires_auth":"none","summary":"The node-ipc library writes a maintainer message to the user's desktop, requiring an upgrade to remove this unwanted behavior.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"node-ipc starting in version 11.0.0 and prior to version 12.0.0 includes a message from the maintainer that is written to the user’s desktop. Please review the version changes before proceeding.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"node-ipc behavior change","id":"GHSA-3mpp-xfvh-qh37","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["12.0.0"],"introduced":["11.0.0"],"last_affected":[],"package":"node-ipc","purl":null,"source":"GHSA-3mpp-xfvh-qh37"},{"ecosystem":"npm","fixed":["12.0.0"],"introduced":["11.0.0"],"last_affected":[],"package":"node-ipc","purl":"pkg:npm/node-ipc","source":"GHSA-3mpp-xfvh-qh37"}],"products":null,"published":"2022-03-16","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The node-ipc library writes a maintainer message to the user's desktop, requiring an upgrade to remove this unwanted behavior.","url":"https://insights.sbomify.com/GHSA-3mpp-xfvh-qh37/"}