GHSA-3qpm-h9ch-px3c Remote code injection, Improper Input Validation and Uncontrolled Recursion in Log4j library
Attackers can execute arbitrary code on servers using the Log4j library by sending malicious messages via the JNDI parser.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-3qpm-h9ch-px3c?
GHSA-3qpm-h9ch-px3c is a code injection vulnerability in org.powernukkit:powernukkit, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Summary
The version used of Log4j, the library used for logging by PowerNukkit, is subject to a remote code execution vulnerability via the ldap JNDI parser. It's well detailed at CVE-2021-44228 and CVE-2021-45105(https://github.com/advisories/GHSA-p6xc-xr62-6r2g).
Impact
Malicious client code could be used to send messages and cause remote code execution on the server.
Patches
PowerNukkit 1.5.2.1 is a patch-release that only updates the Log4j version to 2.17.0 and should be used instead of 1.5.2.0.
All versions prior to 1.5.2.1 are affected and are not patched.
Workarounds
If you can't upgrade, you can use the -Dlog4j2.formatMsgNoLookups=true startup argument as remediation, as this prevents the vulnerability from happening.
References
https://github.com/advisories/GHSA-jfh8-c2jp-5v3q https://github.com/advisories/GHSA-p6xc-xr62-6r2g
For more information
If you have any questions or comments about this advisory:
- Open an issue in the PowerNukkit repository
Which versions are affected by GHSA-3qpm-h9ch-px3c?
2 open source packages ship an affected version, including org.powernukkit:powernukkit.
| Package | Affected | Fixed in |
|---|---|---|
org.powernukkit:powernukkit Maven | All versions | 1.5.2.1 |
org.powernukkit:powernukkit Maven | All versions | 1.5.2.1 |
How do I fix GHSA-3qpm-h9ch-px3c?
Upgrade org.powernukkit:powernukkit to 1.5.2.1 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is GHSA-3qpm-h9ch-px3c being exploited?
There is no known exploitation of GHSA-3qpm-h9ch-px3c in the wild and no public exploit code.