{"answers":{"affected":"2 open source packages ship an affected version, including org.powernukkit:powernukkit.","exploited":"There is no known exploitation of GHSA-3qpm-h9ch-px3c in the wild and no public exploit code.","fix":"Upgrade org.powernukkit:powernukkit to 1.5.2.1 or later.","what":"GHSA-3qpm-h9ch-px3c is a code injection vulnerability in org.powernukkit:powernukkit, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3qpm-h9ch-px3c and fix it if it is affected.\n\nWhat it is: GHSA-3qpm-h9ch-px3c is a code injection vulnerability in org.powernukkit:powernukkit, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3qpm-h9ch-px3c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.powernukkit:powernukkit (Maven): affected all versions; fixed in 1.5.2.1\n- org.powernukkit:powernukkit (Maven): affected all versions; fixed in 1.5.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3qpm-h9ch-px3c/ (Markdown: https://insights.sbomify.com/GHSA-3qpm-h9ch-px3c/index.md)","id":"GHSA-3qpm-h9ch-px3c","markdown":"https://insights.sbomify.com/GHSA-3qpm-h9ch-px3c/index.md","name":"GHSA-3qpm-h9ch-px3c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java logging library","requires_auth":"none","summary":"Attackers can execute arbitrary code on servers using the Log4j library by sending malicious messages via the JNDI parser.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nThe version used of Log4j, the library used for logging by PowerNukkit, is subject to a remote code execution vulnerability via the ldap JNDI parser.\nIt's well detailed at [CVE-2021-44228](https://github.com/advisories/GHSA-jfh8-c2jp-5v3q) and  CVE-2021-45105(https://github.com/advisories/GHSA-p6xc-xr62-6r2g).\n\n### Impact\nMalicious client code could be used to send messages and cause remote code execution on the server.\n\n### Patches\nPowerNukkit `1.5.2.1` is a patch-release that only updates the Log4j version to `2.17.0` and should be used instead of `1.5.2.0`.\nAll versions prior to `1.5.2.1` are affected and are not patched.\n\n### Workarounds\nIf you can't upgrade, you can use the `-Dlog4j2.formatMsgNoLookups=true` startup argument as remediation, as this prevents the vulnerability from happening.\n\n### References\nhttps://github.com/advisories/GHSA-jfh8-c2jp-5v3q\nhttps://github.com/advisories/GHSA-p6xc-xr62-6r2g\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [the PowerNukkit repository](https://github.com/PowerNukkit/PowerNukkit/issues)","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Remote code injection, Improper Input Validation and Uncontrolled Recursion in Log4j library","id":"GHSA-3qpm-h9ch-px3c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["1.5.2.1"],"introduced":["0"],"last_affected":[],"package":"org.powernukkit:powernukkit","purl":null,"source":"GHSA-3qpm-h9ch-px3c"},{"ecosystem":"Maven","fixed":["1.5.2.1"],"introduced":["0"],"last_affected":[],"package":"org.powernukkit:powernukkit","purl":"pkg:maven/org.powernukkit/powernukkit","source":"GHSA-3qpm-h9ch-px3c"}],"products":null,"published":"2022-01-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code on servers using the Log4j library by sending malicious messages via the JNDI parser.","url":"https://insights.sbomify.com/GHSA-3qpm-h9ch-px3c/"}