{"answers":{"affected":"2 open source packages ship an affected version, including curl-cffi.","exploited":"There is no known exploitation of GHSA-3vpc-4p9p-47hc in the wild and no public exploit code.","fix":"Upgrade curl-cffi to 0.7.0b6 or later.","what":"GHSA-3vpc-4p9p-47hc is a vulnerability in curl-cffi, published on 22 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3vpc-4p9p-47hc and fix it if it is affected.\n\nWhat it is: GHSA-3vpc-4p9p-47hc is a vulnerability in curl-cffi, published on 22 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3vpc-4p9p-47hc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- curl-cffi (PyPI): affected all versions; fixed in 0.7.0b6\n- curl-cffi (PyPI): affected all versions; fixed in 0.7.0b6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3vpc-4p9p-47hc/ (Markdown: https://insights.sbomify.com/GHSA-3vpc-4p9p-47hc/index.md)","id":"GHSA-3vpc-4p9p-47hc","markdown":"https://insights.sbomify.com/GHSA-3vpc-4p9p-47hc/index.md","name":"GHSA-3vpc-4p9p-47hc","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python HTTP library","requires_auth":"none","summary":"Attackers can exploit a bundled vulnerable libcurl version in curl_cffi to potentially execute code or read data via network requests.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\ncurl_cffi is potentially affected by High Severity vulnerability (CVE-2023-38545) in libcurl\u003c8.4.0\n\n### Details\nHIGH severity vulnerability in curl and libcurl: [announcement](https://github.com/curl/curl/discussions/12026#discussioncomment-7195548)\nDetails are still unknown, but seems it will be a major issue as it's advertised by curl devs as \"_probably the worst curl security flaw in a long time_\".\nA patched version (8.4.0) and details will be published around 06:00 UTC on October 11.\ncurl_cffi wheels on PyPI ship with libcurl 7.84.0\n\n### PoC\n[https://inspector.pypi.io/project/curl-cffi/0.5.10b2/packages/56/ae/eb7d39ad234f1f44650b910757d5aa696feff413d327c8328223ce78cb76/curl_cffi-0.5.10b2-cp37-abi3-manylinux_2_17_aarch64.manylinux2014_aarch64.whl/curl_cffi/include/curl/curlver.h](https://inspector.pypi.io/project/curl-cffi/0.5.10b2/packages/56/ae/eb7d39ad234f1f44650b910757d5aa696feff413d327c8328223ce78cb76/curl_cffi-0.5.10b2-cp37-abi3-manylinux_2_17_aarch64.manylinux2014_aarch64.whl/curl_cffi/include/curl/curlver.h)\n\n### Resolution\n\nVersions after 0.7 bundles with `libcurl\u003e=8.5`, which is not affected by this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"curl_cffi bundles a version of libcurl affected by High Severity vulnerability","id":"GHSA-3vpc-4p9p-47hc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.7.0b6"],"introduced":["0"],"last_affected":[],"package":"curl-cffi","purl":null,"source":"GHSA-3vpc-4p9p-47hc"},{"ecosystem":"PyPI","fixed":["0.7.0b6"],"introduced":["0"],"last_affected":[],"package":"curl-cffi","purl":"pkg:pypi/curl-cffi","source":"GHSA-3vpc-4p9p-47hc"}],"products":null,"published":"2024-10-22","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit a bundled vulnerable libcurl version in curl_cffi to potentially execute code or read data via network requests.","url":"https://insights.sbomify.com/GHSA-3vpc-4p9p-47hc/"}