# GHSA-3wgq-h4fr-cwg5: laravel-crud-wizard-free has File Validation Bypass

> An attacker can bypass file validation in the Laravel CRUD Wizard package, potentially uploading malicious files to execute code or modify data.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2025

## What is GHSA-3wgq-h4fr-cwg5?

GHSA-3wgq-h4fr-cwg5 is a vulnerability in macropay-solutions/laravel-crud-wizard-free, published on 12 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact
Medium

### Patches
Version 3.4.17 fixes illuminate/validation v 8.0.0 to 11.44.0

### Workarounds
Register \MacropaySolutions\LaravelCrudWizard\Providers\ValidationServiceProvider instead of Illuminate\Validation\ValidationServiceProvider::class if you are using illuminate/validation < 11.44.1

### References
https://github.com/laravel/framework/security/advisories/GHSA-78fx-h6xr-vch4

## Which versions are affected by GHSA-3wgq-h4fr-cwg5?

2 open source packages ship an affected version, including macropay-solutions/laravel-crud-wizard-free.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `macropay-solutions/laravel-crud-wizard-free` | Packagist | All versions | 3.4.17 |
| `macropay-solutions/laravel-crud-wizard-free` | Packagist | All versions | 3.4.17 |

## How do I fix GHSA-3wgq-h4fr-cwg5?

Upgrade macropay-solutions/laravel-crud-wizard-free to 3.4.17 or later.

## Is GHSA-3wgq-h4fr-cwg5 being exploited?

There is no known exploitation of GHSA-3wgq-h4fr-cwg5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-3wgq-h4fr-cwg5 and fix it if it is affected.

What it is: GHSA-3wgq-h4fr-cwg5 is a vulnerability in macropay-solutions/laravel-crud-wizard-free, published on 12 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-3wgq-h4fr-cwg5 in the wild and no public exploit code.

Affected packages and fixed versions:
- macropay-solutions/laravel-crud-wizard-free (Packagist): affected all versions; fixed in 3.4.17
- macropay-solutions/laravel-crud-wizard-free (Packagist): affected all versions; fixed in 3.4.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-3wgq-h4fr-cwg5/ (Markdown: https://insights.sbomify.com/GHSA-3wgq-h4fr-cwg5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-3wgq-h4fr-cwg5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-3wgq-h4fr-cwg5/
Summaries are generated and may contain mistakes; the official description above is the record.
