# GHSA-3wqc-mwfx-672p: Traefik affected by Go oauth2/jws Improper Validation of Syntactic Correctness of Input vulnerability

> Traefik is vulnerable to improper input validation in its OAuth2/JWS library, potentially allowing security bypasses; users should upgrade to patched versions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2025

## What is GHSA-3wqc-mwfx-672p?

GHSA-3wqc-mwfx-672p is a vulnerability in github.com/traefik/traefik/v2, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
We have encountered a security vulnerability being reported by our scanners for Traefik 2.11.22.
- https://security.snyk.io/vuln/SNYK-CHAINGUARDLATEST-TRAEFIK33-9403297

### Details
It seems to target oauth2/jws library.

### PoC
No steps to replicate this vulnerability

### Impact
We have a strict control on security and we always try to stay up-to-date with the fixes received for third-party solutions.

## Patches

- https://github.com/traefik/traefik/releases/tag/v2.11.24
- https://github.com/traefik/traefik/releases/tag/v3.3.6
- https://github.com/traefik/traefik/releases/tag/v3.4.0-rc2

## Which versions are affected by GHSA-3wqc-mwfx-672p?

6 open source packages ship an affected version, including github.com/traefik/traefik/v2 and github.com/traefik/traefik/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.24 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.24 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.3.6 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.3.6 |
| `github.com/traefik/traefik/v3` | Go | From 3.4.0-rc1 | 3.4.0-rc2 |
| `github.com/traefik/traefik/v3` | Go | From 3.4.0-rc1 | 3.4.0-rc2 |

## How do I fix GHSA-3wqc-mwfx-672p?

Upgrade github.com/traefik/traefik/v2 to 2.11.24 or later.

## Is GHSA-3wqc-mwfx-672p being exploited?

There is no known exploitation of GHSA-3wqc-mwfx-672p in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-3wqc-mwfx-672p and fix it if it is affected.

What it is: GHSA-3wqc-mwfx-672p is a vulnerability in github.com/traefik/traefik/v2, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-3wqc-mwfx-672p in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.24
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.24
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.3.6
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.3.6
- github.com/traefik/traefik/v3 (Go): affected from 3.4.0-rc1; fixed in 3.4.0-rc2
- github.com/traefik/traefik/v3 (Go): affected from 3.4.0-rc1; fixed in 3.4.0-rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-3wqc-mwfx-672p/ (Markdown: https://insights.sbomify.com/GHSA-3wqc-mwfx-672p/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-3wqc-mwfx-672p

---
From sbomify Insights: https://insights.sbomify.com/GHSA-3wqc-mwfx-672p/
Summaries are generated and may contain mistakes; the official description above is the record.
