{"answers":{"affected":"2 open source packages ship an affected version, including @hapi/content.","exploited":"There is no known exploitation of GHSA-3wqh-h42r-x8fq in the wild and no public exploit code.","fix":"Upgrade @hapi/content to 5.0.2 or later.","what":"GHSA-3wqh-h42r-x8fq is a denial of service vulnerability in @hapi/content, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3wqh-h42r-x8fq and fix it if it is affected.\n\nWhat it is: GHSA-3wqh-h42r-x8fq is a denial of service vulnerability in @hapi/content, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3wqh-h42r-x8fq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @hapi/content (npm): affected all versions; fixed in 5.0.2\n- @hapi/content (npm): affected all versions; fixed in 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3wqh-h42r-x8fq/ (Markdown: https://insights.sbomify.com/GHSA-3wqh-h42r-x8fq/index.md)","id":"GHSA-3wqh-h42r-x8fq","markdown":"https://insights.sbomify.com/GHSA-3wqh-h42r-x8fq/index.md","name":"GHSA-3wqh-h42r-x8fq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP library","requires_auth":"none","summary":"An attacker can crash the application by sending a malformed Content-Encoding header, causing a system error that terminates the service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `@hapi/content` prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.\n\n## Recommendation\n\nUpgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in @hapi/content","id":"GHSA-3wqh-h42r-x8fq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"@hapi/content","purl":null,"source":"GHSA-3wqh-h42r-x8fq"},{"ecosystem":"npm","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"@hapi/content","purl":"pkg:npm/%40hapi/content","source":"GHSA-3wqh-h42r-x8fq"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can crash the application by sending a malformed Content-Encoding header, causing a system error that terminates the service.","url":"https://insights.sbomify.com/GHSA-3wqh-h42r-x8fq/"}