# GHSA-3wqh-h42r-x8fq: Denial of Service in @hapi/content

> An attacker can crash the application by sending a malformed Content-Encoding header, causing a system error that terminates the service.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2020

## What is GHSA-3wqh-h42r-x8fq?

GHSA-3wqh-h42r-x8fq is a denial of service vulnerability in @hapi/content, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of `@hapi/content` prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

## Recommendation

Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.

## Which versions are affected by GHSA-3wqh-h42r-x8fq?

2 open source packages ship an affected version, including @hapi/content.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hapi/content` | npm | All versions | 5.0.2 |
| `@hapi/content` | npm | All versions | 5.0.2 |

## How do I fix GHSA-3wqh-h42r-x8fq?

Upgrade @hapi/content to 5.0.2 or later.

## Is GHSA-3wqh-h42r-x8fq being exploited?

There is no known exploitation of GHSA-3wqh-h42r-x8fq in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-3wqh-h42r-x8fq and fix it if it is affected.

What it is: GHSA-3wqh-h42r-x8fq is a denial of service vulnerability in @hapi/content, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-3wqh-h42r-x8fq in the wild and no public exploit code.

Affected packages and fixed versions:
- @hapi/content (npm): affected all versions; fixed in 5.0.2
- @hapi/content (npm): affected all versions; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-3wqh-h42r-x8fq/ (Markdown: https://insights.sbomify.com/GHSA-3wqh-h42r-x8fq/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-3wqh-h42r-x8fq

---
From sbomify Insights: https://insights.sbomify.com/GHSA-3wqh-h42r-x8fq/
Summaries are generated and may contain mistakes; the official description above is the record.
