GHSA-3wxm-m9m4-cprj Import of incorrectly embargoed keys could cause early publication
Importing keys from non-compliant servers allows early publication and potential replay of Random Proximity Identifiers, impacting privacy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-3wxm-m9m4-cprj?
GHSA-3wxm-m9m4-cprj is a vulnerability in github.com/google/exposure-notifications-server, published on 21 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
If your installation is using the export-importer service, there is potential impact.
If your installation is not importing keys via the export-importer services, your installation is not impacted.
In versions 0.19.1 and earlier, the export-importer service assumed that the server it was importing from had properly embargoed keys for at least 2 hours after their expiry time. There are now known instances of servers that did not properly embargo keys.
This could allow allow for imported keys to be re-published before they have expired, allowing for potential replay of RPIs.
Patches
This is patched in v0.18.3 and all versions 0.19.2 and later.
Workarounds
Ensure that the servers you are importing export zip files from are not publishing keys too early.
References
n/a
For more information
If you have any questions or comments about this advisory
- Open an issue in exposure-notifications-server
- Email us at [email protected]
Which versions are affected by GHSA-3wxm-m9m4-cprj?
5 open source packages ship an affected version, including github.com/google/exposure-notifications-server.
| Package | Affected | Fixed in |
|---|---|---|
github.com/google/exposure-notifications-server Go | All versions | 0.18.3, 0.19.2 |
github.com/google/exposure-notifications-server Go | All versions | 0.18.3 |
github.com/google/exposure-notifications-server Go | All versions | 0.18.3 |
github.com/google/exposure-notifications-server Go | From 0.19.0 | 0.19.2 |
github.com/google/exposure-notifications-server Go | From 0.19.0 | 0.19.2 |
How do I fix GHSA-3wxm-m9m4-cprj?
Upgrade github.com/google/exposure-notifications-server to a fixed version for your release line: 0.18.3 or 0.19.2.
Is GHSA-3wxm-m9m4-cprj being exploited?
There is no known exploitation of GHSA-3wxm-m9m4-cprj in the wild and no public exploit code.
Sources
Also known as GO-2022-0381.