{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendopenid.","exploited":"There is no known exploitation of GHSA-3x57-m5p4-rgh4 in the wild and no public exploit code.","fix":"Upgrade zendframework/zendopenid to 2.0.2 or later.","what":"GHSA-3x57-m5p4-rgh4 is an authentication bypass vulnerability in zendframework/zendopenid, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-3x57-m5p4-rgh4 and fix it if it is affected.\n\nWhat it is: GHSA-3x57-m5p4-rgh4 is an authentication bypass vulnerability in zendframework/zendopenid, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-3x57-m5p4-rgh4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendopenid (Packagist): affected from 2.0.0; fixed in 2.0.2\n- zendframework/zendopenid (Packagist): affected from 2.0.0; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3x57-m5p4-rgh4/ (Markdown: https://insights.sbomify.com/GHSA-3x57-m5p4-rgh4/index.md)","id":"GHSA-3x57-m5p4-rgh4","markdown":"https://insights.sbomify.com/GHSA-3x57-m5p4-rgh4/index.md","name":"GHSA-3x57-m5p4-rgh4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP OpenID library","requires_auth":"none","summary":"Attackers can impersonate any OpenID identity by exploiting insufficient signature validation in the ZendOpenID Consumer component.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Using the Consumer component of ZendOpenId (or Zend_OpenId in ZF1), it is possible to login using an arbitrary OpenID account (without knowing any secret information) by using a malicious OpenID Provider. That means OpenID it is possible to login using arbitrary OpenID Identity (MyOpenID, Google, etc), which are not under the control of our own OpenID Provider. Thus, we are able to impersonate any OpenID Identity against the framework.\n\nMoreover, the Consumer accepts OpenID tokens with arbitrary signed elements. The framework does not check if, for example, both openid.claimed_id and openid.endpoint_url are signed. It is just sufficient to sign one parameter. According to https://openid.net/specs/openid-authentication-2_0.html#positive_assertions, at least op_endpoint, return_to, response_nonce, assoc_handle, and, if present in the response, claimed_id and identity, must be signed.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendOpenID potential security issue in login mechanism","id":"GHSA-3x57-m5p4-rgh4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendopenid","purl":null,"source":"GHSA-3x57-m5p4-rgh4"},{"ecosystem":"Packagist","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"zendframework/zendopenid","purl":"pkg:composer/zendframework/zendopenid","source":"GHSA-3x57-m5p4-rgh4"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can impersonate any OpenID identity by exploiting insufficient signature validation in the ZendOpenID Consumer component.","url":"https://insights.sbomify.com/GHSA-3x57-m5p4-rgh4/"}