{"answers":{"affected":"2 open source packages ship an affected version, including org.opensearch.dataprepper.plugins:geoip-processor.","exploited":"There is no known exploitation of GHSA-3xgr-h5hq-7299 in the wild and no public exploit code.","fix":"Upgrade org.opensearch.dataprepper.plugins:geoip-processor to 2.12.2 or later.","what":"GHSA-3xgr-h5hq-7299 is a vulnerability in org.opensearch.dataprepper.plugins:geoip-processor, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-3xgr-h5hq-7299 and fix it if it is affected.\n\nWhat it is: GHSA-3xgr-h5hq-7299 is a vulnerability in org.opensearch.dataprepper.plugins:geoip-processor, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-3xgr-h5hq-7299 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opensearch.dataprepper.plugins:geoip-processor (Maven): affected from 2.7.0; fixed in 2.12.2\n- org.opensearch.dataprepper.plugins:geoip-processor (Maven): affected from 2.7.0; fixed in 2.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-3xgr-h5hq-7299/ (Markdown: https://insights.sbomify.com/GHSA-3xgr-h5hq-7299/index.md)","id":"GHSA-3xgr-h5hq-7299","markdown":"https://insights.sbomify.com/GHSA-3xgr-h5hq-7299/index.md","name":"GHSA-3xgr-h5hq-7299","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Data Prepper GeoIP processor","requires_auth":"none","summary":"The GeoIP processor disables SSL validation, allowing man-in-the-middle attacks to serve malicious geolocation databases during downloads.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe GeoIP processor in Data Prepper was configured to trust all SSL certificates and disable hostname verification when downloading GeoIP databases from HTTP URLs, making downloads vulnerable to man-in-the-middle attacks.\n\nThe GeoIP processor included a custom SSL implementation that completely bypassed certificate validation when downloading GeoIP databases from external sources. The `initiateSSL()` method incorrectly implemented an approach for trusting all certificates. Specifically it:\n\n* Accepted all SSL certificates without validation\n* Disabled server certificate verification\n* Disabled client certificate verification\n* Disabled hostname verification\n\nThis configuration made database downloads vulnerable to man-in-the-middle attacks, potentially allowing attackers to serve malicious GeoIP databases that could compromise the integrity of geolocation data processing.\n\n### Patches\n\nData Prepper 2.12.2 contains a fix for this issue.\n\n### Workarounds\n\nIf upgrading is not immediately possible:\n\n* Use local GeoIP database files instead of downloading from HTTP URLs\n* Ensure database downloads occur only over trusted networks","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"GeoIP processor disables SSL certificate validation when downloading databases","id":"GHSA-3xgr-h5hq-7299","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.12.2"],"introduced":["2.7.0"],"last_affected":[],"package":"org.opensearch.dataprepper.plugins:geoip-processor","purl":null,"source":"GHSA-3xgr-h5hq-7299"},{"ecosystem":"Maven","fixed":["2.12.2"],"introduced":["2.7.0"],"last_affected":[],"package":"org.opensearch.dataprepper.plugins:geoip-processor","purl":"pkg:maven/org.opensearch.dataprepper.plugins/geoip-processor","source":"GHSA-3xgr-h5hq-7299"}],"products":null,"published":"2025-10-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The GeoIP processor disables SSL validation, allowing man-in-the-middle attacks to serve malicious geolocation databases during downloads.","url":"https://insights.sbomify.com/GHSA-3xgr-h5hq-7299/"}