# GHSA-443w-3rq3-5m5h: AWS SDK for Java 2.0: Improper Handling of Special Characters in CloudFront Signing Utilities

> Improper handling of special characters in CloudFront signing utilities may allow bypassing intended access restrictions in signed URLs or cookies.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026

## What is GHSA-443w-3rq3-5m5h?

GHSA-443w-3rq3-5m5h is a vulnerability in software.amazon.awssdk:cloudfront, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
This notification is related to the [CloudFront signing utilities](https://github.com/aws/aws-sdk-java-v2/blob/master/services/cloudfront/src/main/java/software/amazon/awssdk/services/cloudfront/CloudFrontUtilities.java) in the AWS SDK for Java v2, which are used to generate Amazon CloudFront signed URLs and signed cookies. A defense-in-depth enhancement has been implemented to improve handling of special characters, such as double quotes and backslashes, in input values.
### Impact
The CloudFront signing utilities build policy documents that define access restrictions for signed URLs and cookies. If an application passes unsanitized input containing special characters to these utilities, the resulting policy document may not reflect the application's intended access restrictions. While the SDK was functioning safely within the requirements of the shared responsibility model, additional safeguards have been added to support secure customer implementations. Applications that already follow AWS security best practices for input validation are not impacted.
### Impacted versions: 
2.18.33 - 2.41.29
### Patches
On 2026.02.16, an enhancement was made to AWS SDK for Java v2 version 2.41.30. The enhancement ensures that special characters in input values are correctly handled. We recommend upgrading to the latest version.
### Workarounds
No workarounds are needed, but customers should ensure that your application is following security best practices:

* Implement proper input validation in your application code before passing values to CloudFront signing utilities
* Update to the latest AWS SDK release on a regular basis
* Follow [AWS security best practices for SDK configuration](https://docs.aws.amazon.com/sdk-for-java/latest/developer-guide/security.html)

### Resources
If there are any questions or comments about this advisory, contact [AWS/Amazon] Security via our vulnerability reporting page or directly via email to [aws-security@amazon.com](mailto:aws-security@amazon.com). Please do not create a public GitHub issue.
### Acknowledgement
AWS SDK for Java 2.0 thanks the Amazon Inspector Security Research team for identifying this issue and working with us through the coordinated process.

## Which versions are affected by GHSA-443w-3rq3-5m5h?

2 open source packages ship an affected version, including software.amazon.awssdk:cloudfront.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `software.amazon.awssdk:cloudfront` | Maven | From 2.18.33 | 2.41.30 |
| `software.amazon.awssdk:cloudfront` | Maven | From 2.18.33 | 2.41.30 |

## How do I fix GHSA-443w-3rq3-5m5h?

Upgrade software.amazon.awssdk:cloudfront to 2.41.30 or later.

## Is GHSA-443w-3rq3-5m5h being exploited?

There is no known exploitation of GHSA-443w-3rq3-5m5h in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-443w-3rq3-5m5h and fix it if it is affected.

What it is: GHSA-443w-3rq3-5m5h is a vulnerability in software.amazon.awssdk:cloudfront, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-443w-3rq3-5m5h in the wild and no public exploit code.

Affected packages and fixed versions:
- software.amazon.awssdk:cloudfront (Maven): affected from 2.18.33; fixed in 2.41.30
- software.amazon.awssdk:cloudfront (Maven): affected from 2.18.33; fixed in 2.41.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-443w-3rq3-5m5h/ (Markdown: https://insights.sbomify.com/GHSA-443w-3rq3-5m5h/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-443w-3rq3-5m5h

---
From sbomify Insights: https://insights.sbomify.com/GHSA-443w-3rq3-5m5h/
Summaries are generated and may contain mistakes; the official description above is the record.
