# GHSA-44m4-9cjp-j587: IBX-1392: Image filenames sanitization

> Attackers can access unauthorized image files via unsanitized filenames in the eZ Publish kernel, requiring an upgrade to mitigate.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2022

## What is GHSA-44m4-9cjp-j587?

GHSA-44m4-9cjp-j587 is a path traversal vulnerability in ezsystems/ezpublish-kernel, published on 21 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ezsystems/ezpublish-kernel versions 7.5.* before 7.5.26 are vulnerable to certain injection attacks and unauthorized access to some image files.

## Which versions are affected by GHSA-44m4-9cjp-j587?

2 open source packages ship an affected version, including ezsystems/ezpublish-kernel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezpublish-kernel` | Packagist | From 7.5.0 | 7.5.26 |
| `ezsystems/ezpublish-kernel` | Packagist | From 7.5.0 | 7.5.26 |

## How do I fix GHSA-44m4-9cjp-j587?

Upgrade ezsystems/ezpublish-kernel to 7.5.26 or later.

## Is GHSA-44m4-9cjp-j587 being exploited?

There is no known exploitation of GHSA-44m4-9cjp-j587 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-44m4-9cjp-j587 and fix it if it is affected.

What it is: GHSA-44m4-9cjp-j587 is a path traversal vulnerability in ezsystems/ezpublish-kernel, published on 21 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-44m4-9cjp-j587 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezpublish-kernel (Packagist): affected from 7.5.0; fixed in 7.5.26
- ezsystems/ezpublish-kernel (Packagist): affected from 7.5.0; fixed in 7.5.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-44m4-9cjp-j587/ (Markdown: https://insights.sbomify.com/GHSA-44m4-9cjp-j587/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-44m4-9cjp-j587

---
From sbomify Insights: https://insights.sbomify.com/GHSA-44m4-9cjp-j587/
Summaries are generated and may contain mistakes; the official description above is the record.
