GHSA-457r-cqc8-9vj9 sweetalert2 v10.16.10 and above contains hidden functionality
The library contains hidden audio/video functionality not intended for its purpose, potentially causing unexpected behavior or resource usage in applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-457r-cqc8-9vj9?
GHSA-457r-cqc8-9vj9 is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
sweetalert2 versions 10.16.10 and up until 11.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 10.0.0 - 10.16.9.
Workaround
Use a version 10.0.0 - 10.16.9 of the package until the maintainer releases a fix.
Which versions are affected by GHSA-457r-cqc8-9vj9?
2 open source packages ship an affected version, including sweetalert2.
| Package | Affected | Fixed in |
|---|---|---|
sweetalert2 npm | From 10.16.10 | 11.22.4 |
sweetalert2 npm | From 10.16.10 | 11.22.4 |
How do I fix GHSA-457r-cqc8-9vj9?
Upgrade sweetalert2 to 11.22.4 or later.
Is GHSA-457r-cqc8-9vj9 being exploited?
There is no known exploitation of GHSA-457r-cqc8-9vj9 in the wild and no public exploit code.