# GHSA-45qm-j4m9-whv9: eZ Platform CSRF token in login form is disabled by default

> Attackers can perform CSRF attacks on the login form because CSRF protection is disabled by default, requiring manual configuration to enable.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-45qm-j4m9-whv9?

GHSA-45qm-j4m9-whv9 is a vulnerability in ezsystems/ezplatform, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

his security advisory fixes a potential vulnerability in the eZ Platform log in form. That form has a Cross-Site Request Forgery (CSRF) token, but the CSRF functionality is not enabled by default, meaning the token is inactive. The fix is distributed via Composer as ezsystems/ezplatform v2.5.4, and in v3.0.0 when that will be released.

If you'd like to manually enable it in your configuration, this is done by editing your app/config/security.yml and setting the "csrf_token_generator" key to "security.csrf.token_manager", like this:
```
security:
    firewalls:
        ezpublish_front:
            form_login:
                csrf_token_generator: security.csrf.token_manager
```
NB: In eZ Platform 3.0 this file has been moved to config/packages/security.yaml

## Which versions are affected by GHSA-45qm-j4m9-whv9?

2 open source packages ship an affected version, including ezsystems/ezplatform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezplatform` | Packagist | From 2.5.0 | 2.5.4 |
| `ezsystems/ezplatform` | Packagist | From 2.5.0 | 2.5.4 |

## How do I fix GHSA-45qm-j4m9-whv9?

Upgrade ezsystems/ezplatform to 2.5.4 or later.

## Is GHSA-45qm-j4m9-whv9 being exploited?

There is no known exploitation of GHSA-45qm-j4m9-whv9 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-45qm-j4m9-whv9 and fix it if it is affected.

What it is: GHSA-45qm-j4m9-whv9 is a vulnerability in ezsystems/ezplatform, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-45qm-j4m9-whv9 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezplatform (Packagist): affected from 2.5.0; fixed in 2.5.4
- ezsystems/ezplatform (Packagist): affected from 2.5.0; fixed in 2.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-45qm-j4m9-whv9/ (Markdown: https://insights.sbomify.com/GHSA-45qm-j4m9-whv9/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-45qm-j4m9-whv9

---
From sbomify Insights: https://insights.sbomify.com/GHSA-45qm-j4m9-whv9/
Summaries are generated and may contain mistakes; the official description above is the record.
