{"answers":{"affected":"2 open source packages ship an affected version, including s2n-quic.","exploited":"There is no known exploitation of GHSA-475v-pq2g-fp9g in the wild and no public exploit code.","fix":"Upgrade s2n-quic to 1.31.0 or later.","what":"GHSA-475v-pq2g-fp9g is a denial of service vulnerability in s2n-quic, published on 8 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-475v-pq2g-fp9g and fix it if it is affected.\n\nWhat it is: GHSA-475v-pq2g-fp9g is a denial of service vulnerability in s2n-quic, published on 8 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-475v-pq2g-fp9g in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- s2n-quic (crates.io): affected all versions; fixed in 1.31.0\n- s2n-quic (crates.io): affected all versions; fixed in 1.31.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-475v-pq2g-fp9g/ (Markdown: https://insights.sbomify.com/GHSA-475v-pq2g-fp9g/index.md)","id":"GHSA-475v-pq2g-fp9g","markdown":"https://insights.sbomify.com/GHSA-475v-pq2g-fp9g/index.md","name":"GHSA-475v-pq2g-fp9g","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"QUIC protocol library","requires_auth":"none","summary":"Attackers can cause denial of service by opening streams beyond limits, requiring library upgrade to mitigate resource exhaustion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nAn issue in s2n-quic could result in unnecessary resource utilization when peers open streams beyond advertised limits.\n\nImpacted versions: \u003c= v1.30.0.\n\n### Patches\nThe patch is included in v1.31.0 [1].\n\n### Workarounds\nThere is no workaround. Applications using s2n-quic should upgrade to the most recent release of s2n-quic.\n\nIf you have any questions or comments about this advisory, we ask that you contact AWS Security via our vulnerability reporting page [2] or directly via email to [aws-security@amazon.com](mailto:aws-security@amazon.com). Please do not create a public GitHub issue.\n\n[1] https://github.com/aws/s2n-quic/releases/tag/v1.31.0\n[2] https://aws.amazon.com/security/vulnerability-reporting","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"s2n-quic potential denial of service via crafted stream frames","id":"GHSA-475v-pq2g-fp9g","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["1.31.0"],"introduced":["0"],"last_affected":[],"package":"s2n-quic","purl":null,"source":"GHSA-475v-pq2g-fp9g"},{"ecosystem":"crates.io","fixed":["1.31.0"],"introduced":["0"],"last_affected":[],"package":"s2n-quic","purl":"pkg:cargo/s2n-quic","source":"GHSA-475v-pq2g-fp9g"}],"products":null,"published":"2023-11-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service by opening streams beyond limits, requiring library upgrade to mitigate resource exhaustion.","url":"https://insights.sbomify.com/GHSA-475v-pq2g-fp9g/"}