{"answers":{"affected":"2 open source packages ship an affected version, including commonmarker.","exploited":"There is no known exploitation of GHSA-48wp-p9qv-4j64 in the wild and no public exploit code.","fix":"Upgrade commonmarker to 0.23.9 or later.","what":"GHSA-48wp-p9qv-4j64 is a denial of service vulnerability in commonmarker, published on 11 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-48wp-p9qv-4j64 and fix it if it is affected.\n\nWhat it is: GHSA-48wp-p9qv-4j64 is a denial of service vulnerability in commonmarker, published on 11 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-48wp-p9qv-4j64 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.9\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-48wp-p9qv-4j64/ (Markdown: https://insights.sbomify.com/GHSA-48wp-p9qv-4j64/index.md)","id":"GHSA-48wp-p9qv-4j64","markdown":"https://insights.sbomify.com/GHSA-48wp-p9qv-4j64/index.md","name":"GHSA-48wp-p9qv-4j64","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Markdown library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using commonmarker by submitting crafted input that triggers quadratic complexity bugs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\nSeveral quadratic complexity bugs in commonmarker's underlying [`cmark-gfm`](https://github.com/github/cmark-gfm) library may lead to unbounded resource exhaustion and subsequent denial of service.\n\nThe following vulnerabilities were addressed:\n\n* [CVE-2023-24824](https://github.com/github/cmark-gfm/security/advisories/GHSA-66g8-4hjf-77xh)\n* [CVE-2023-26485](https://github.com/github/cmark-gfm/security/advisories/GHSA-r8vr-c48j-fcc5)\n\nFor more information, consult the release notes for version [`0.23.0.gfm.10`](https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.10) and [`0.23.0.gfm.11`](https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.11).\n\n## Mitigation\n\nUsers are advised to upgrade to commonmarker version [`0.23.9`](https://rubygems.org/gems/commonmarker/versions/0.23.9).","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Commonmarker vulnerable to to several quadratic complexity bugs that may lead to denial of service","id":"GHSA-48wp-p9qv-4j64","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["0.23.9"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":null,"source":"GHSA-48wp-p9qv-4j64"},{"ecosystem":"RubyGems","fixed":["0.23.9"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":"pkg:gem/commonmarker","source":"GHSA-48wp-p9qv-4j64"}],"products":null,"published":"2023-04-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in applications using commonmarker by submitting crafted input that triggers quadratic complexity bugs.","url":"https://insights.sbomify.com/GHSA-48wp-p9qv-4j64/"}