# GHSA-48wp-p9qv-4j64: Commonmarker vulnerable to to several quadratic complexity bugs that may lead to denial of service

> Attackers can cause denial of service in applications using commonmarker by submitting crafted input that triggers quadratic complexity bugs.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2023

## What is GHSA-48wp-p9qv-4j64?

GHSA-48wp-p9qv-4j64 is a denial of service vulnerability in commonmarker, published on 11 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

## Impact

Several quadratic complexity bugs in commonmarker's underlying [`cmark-gfm`](https://github.com/github/cmark-gfm) library may lead to unbounded resource exhaustion and subsequent denial of service.

The following vulnerabilities were addressed:

* [CVE-2023-24824](https://github.com/github/cmark-gfm/security/advisories/GHSA-66g8-4hjf-77xh)
* [CVE-2023-26485](https://github.com/github/cmark-gfm/security/advisories/GHSA-r8vr-c48j-fcc5)

For more information, consult the release notes for version [`0.23.0.gfm.10`](https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.10) and [`0.23.0.gfm.11`](https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.11).

## Mitigation

Users are advised to upgrade to commonmarker version [`0.23.9`](https://rubygems.org/gems/commonmarker/versions/0.23.9).

## Which versions are affected by GHSA-48wp-p9qv-4j64?

2 open source packages ship an affected version, including commonmarker.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `commonmarker` | RubyGems | All versions | 0.23.9 |
| `commonmarker` | RubyGems | All versions | 0.23.9 |

## How do I fix GHSA-48wp-p9qv-4j64?

Upgrade commonmarker to 0.23.9 or later.

## Is GHSA-48wp-p9qv-4j64 being exploited?

There is no known exploitation of GHSA-48wp-p9qv-4j64 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-48wp-p9qv-4j64 and fix it if it is affected.

What it is: GHSA-48wp-p9qv-4j64 is a denial of service vulnerability in commonmarker, published on 11 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-48wp-p9qv-4j64 in the wild and no public exploit code.

Affected packages and fixed versions:
- commonmarker (RubyGems): affected all versions; fixed in 0.23.9
- commonmarker (RubyGems): affected all versions; fixed in 0.23.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-48wp-p9qv-4j64/ (Markdown: https://insights.sbomify.com/GHSA-48wp-p9qv-4j64/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-48wp-p9qv-4j64

---
From sbomify Insights: https://insights.sbomify.com/GHSA-48wp-p9qv-4j64/
Summaries are generated and may contain mistakes; the official description above is the record.
