{"answers":{"affected":"4 open source packages ship an affected version, including CefSharp.Common and CefSharp.Common.NETCore.","exploited":"There is no known exploitation of GHSA-4c29-gfrp-g6x9 in the wild and no public exploit code.","fix":"Upgrade CefSharp.Common to 117.2.20 or later.","what":"GHSA-4c29-gfrp-g6x9 is a memory corruption vulnerability in CefSharp.Common, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-4c29-gfrp-g6x9 and fix it if it is affected.\n\nWhat it is: GHSA-4c29-gfrp-g6x9 is a memory corruption vulnerability in CefSharp.Common, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-4c29-gfrp-g6x9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- CefSharp.Common (NuGet): affected all versions; fixed in 117.2.20\n- CefSharp.Common (NuGet): affected all versions; fixed in 117.2.20\n- CefSharp.Common.NETCore (NuGet): affected all versions; fixed in 117.2.20\n- CefSharp.Common.NETCore (NuGet): affected all versions; fixed in 117.2.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4c29-gfrp-g6x9/ (Markdown: https://insights.sbomify.com/GHSA-4c29-gfrp-g6x9/index.md)","id":"GHSA-4c29-gfrp-g6x9","markdown":"https://insights.sbomify.com/GHSA-4c29-gfrp-g6x9/index.md","name":"GHSA-4c29-gfrp-g6x9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CefSharp library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via heap corruption in libvpx when users visit crafted HTML pages using CefSharp.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Google is aware that an exploit for CVE-2023-5217 exists in the wild.\n\nDescription\nHeap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)\n\nReferences\n- https://www.cve.org/CVERecord?id=CVE-2023-5217\n- https://nvd.nist.gov/vuln/detail/CVE-2023-5217","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"CefSharp affected by libvpx's heap buffer overflow in vp8 encoding","id":"GHSA-4c29-gfrp-g6x9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["117.2.20"],"introduced":["0"],"last_affected":[],"package":"CefSharp.Common","purl":null,"source":"GHSA-4c29-gfrp-g6x9"},{"ecosystem":"NuGet","fixed":["117.2.20"],"introduced":["0"],"last_affected":[],"package":"CefSharp.Common","purl":"pkg:nuget/CefSharp.Common","source":"GHSA-4c29-gfrp-g6x9"},{"ecosystem":"NuGet","fixed":["117.2.20"],"introduced":["0"],"last_affected":[],"package":"CefSharp.Common.NETCore","purl":null,"source":"GHSA-4c29-gfrp-g6x9"},{"ecosystem":"NuGet","fixed":["117.2.20"],"introduced":["0"],"last_affected":[],"package":"CefSharp.Common.NETCore","purl":"pkg:nuget/CefSharp.Common.NETCore","source":"GHSA-4c29-gfrp-g6x9"}],"products":null,"published":"2023-10-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote attackers can execute arbitrary code via heap corruption in libvpx when users visit crafted HTML pages using CefSharp.","url":"https://insights.sbomify.com/GHSA-4c29-gfrp-g6x9/"}