# GHSA-4c29-gfrp-g6x9: CefSharp affected by libvpx's heap buffer overflow in vp8 encoding

> Remote attackers can execute arbitrary code via heap corruption in libvpx when users visit crafted HTML pages using CefSharp.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2023

## What is GHSA-4c29-gfrp-g6x9?

GHSA-4c29-gfrp-g6x9 is a memory corruption vulnerability in CefSharp.Common, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Google is aware that an exploit for CVE-2023-5217 exists in the wild.

Description
Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

References
- https://www.cve.org/CVERecord?id=CVE-2023-5217
- https://nvd.nist.gov/vuln/detail/CVE-2023-5217

## Which versions are affected by GHSA-4c29-gfrp-g6x9?

4 open source packages ship an affected version, including CefSharp.Common and CefSharp.Common.NETCore.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `CefSharp.Common` | NuGet | All versions | 117.2.20 |
| `CefSharp.Common` | NuGet | All versions | 117.2.20 |
| `CefSharp.Common.NETCore` | NuGet | All versions | 117.2.20 |
| `CefSharp.Common.NETCore` | NuGet | All versions | 117.2.20 |

## How do I fix GHSA-4c29-gfrp-g6x9?

Upgrade CefSharp.Common to 117.2.20 or later.

## Is GHSA-4c29-gfrp-g6x9 being exploited?

There is no known exploitation of GHSA-4c29-gfrp-g6x9 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-4c29-gfrp-g6x9 and fix it if it is affected.

What it is: GHSA-4c29-gfrp-g6x9 is a memory corruption vulnerability in CefSharp.Common, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-4c29-gfrp-g6x9 in the wild and no public exploit code.

Affected packages and fixed versions:
- CefSharp.Common (NuGet): affected all versions; fixed in 117.2.20
- CefSharp.Common (NuGet): affected all versions; fixed in 117.2.20
- CefSharp.Common.NETCore (NuGet): affected all versions; fixed in 117.2.20
- CefSharp.Common.NETCore (NuGet): affected all versions; fixed in 117.2.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-4c29-gfrp-g6x9/ (Markdown: https://insights.sbomify.com/GHSA-4c29-gfrp-g6x9/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-4c29-gfrp-g6x9

---
From sbomify Insights: https://insights.sbomify.com/GHSA-4c29-gfrp-g6x9/
Summaries are generated and may contain mistakes; the official description above is the record.
