# GHSA-4c5f-9mj4-m247: flagd: Multiple Go Runtime CVEs Impact Security and Availability

> Attackers can cause denial of service or data corruption in flagd by exploiting multiple Go standard library vulnerabilities via crafted inputs.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Also known as:** GO-2026-4279

## What is GHSA-4c5f-9mj4-m247?

GHSA-4c5f-9mj4-m247 is a denial of service vulnerability in github.com/open-feature/flagd/core, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
In 2025, several vulnerabilities in the Go Standard Library were disclosed, impacting Go-based applications like flagd (the evaluation engine for OpenFeature). These CVEs primarily focus on Denial of Service (DoS) through resource exhaustion and Race Conditions in database handling. 

| CVE ID | Impacted Package | Severity | Description & Impact on flagd |
| -- | -- | -- | -- |
| CVE-2025-47907 | database/sql | 7.0 (High) | Race Condition:  Canceling a query during a Scan call can return data from the wrong query. Critical if flagd uses SQL-based sync providers (e.g., Postgres), potentially leading to incorrect flag configurations. |
| CVE-2025-61725 | net/mail | 7.5 (High) | DoS: Inefficient complexity in ParseAddress.  Attackers can provide crafted email strings with large domain literals to exhaust CPU if flagd parses email-formatted metadata. |
| CVE-2025-61723 | encoding/pem | 7.5 (High) | DoS: Quadratic complexity when parsing invalid PEM inputs. Relevant if flagd loads TLS certificates or keys via PEM files from untrusted sources. |
| CVE-2025-61729 | crypto/x509 | 7.5 (High) | Resource Exhaustion: HostnameError.Error() lacks string concatenation limits. A malicious TLS certificate with thousands of hostnames could crash flagd during connection handshakes. |
| CVE-2025-58188 | net/http | Medium | Request Smuggling: Improper header handling in HTTP/1.1. Could allow attackers to bypass security filters positioned in front of flagd sync or evaluation APIs. |
| CVE-2025-58187 | archive/zip | Medium | DoS:  Improper validation of malformed ZIP archives.  Impacts flagd if configured to fetch and unpack zipped configuration bundles from remote providers. |

## Which versions are affected by GHSA-4c5f-9mj4-m247?

9 open source packages ship an affected version, including github.com/open-feature/flagd/core, github.com/open-feature/flagd/flagd and github.com/open-feature/flagd/flagd-proxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/open-feature/flagd/core` | Go | All versions | 0.13.1 |
| `github.com/open-feature/flagd/core` | Go | All versions | 0.13.1 |
| `github.com/open-feature/flagd/core` | Go | All versions | 0.13.1 |
| `github.com/open-feature/flagd/flagd` | Go | All versions | 0.13.1 |
| `github.com/open-feature/flagd/flagd` | Go | All versions | 0.13.1 |
| `github.com/open-feature/flagd/flagd` | Go | All versions | 0.13.1 |
| `github.com/open-feature/flagd/flagd-proxy` | Go | All versions | 0.8.2 |
| `github.com/open-feature/flagd/flagd-proxy` | Go | All versions | 0.8.2 |
| `github.com/open-feature/flagd/flagd-proxy` | Go | All versions | 0.8.2 |

## How do I fix GHSA-4c5f-9mj4-m247?

Upgrade github.com/open-feature/flagd/core to 0.13.1 or later.

## Is GHSA-4c5f-9mj4-m247 being exploited?

There is no known exploitation of GHSA-4c5f-9mj4-m247 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-4c5f-9mj4-m247 and fix it if it is affected.

What it is: GHSA-4c5f-9mj4-m247 is a denial of service vulnerability in github.com/open-feature/flagd/core, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-4c5f-9mj4-m247 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/open-feature/flagd/core (Go): affected all versions; fixed in 0.13.1
- github.com/open-feature/flagd/core (Go): affected all versions; fixed in 0.13.1
- github.com/open-feature/flagd/core (Go): affected all versions; fixed in 0.13.1
- github.com/open-feature/flagd/flagd (Go): affected all versions; fixed in 0.13.1
- github.com/open-feature/flagd/flagd (Go): affected all versions; fixed in 0.13.1
- github.com/open-feature/flagd/flagd (Go): affected all versions; fixed in 0.13.1
- github.com/open-feature/flagd/flagd-proxy (Go): affected all versions; fixed in 0.8.2
- github.com/open-feature/flagd/flagd-proxy (Go): affected all versions; fixed in 0.8.2
- github.com/open-feature/flagd/flagd-proxy (Go): affected all versions; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-4c5f-9mj4-m247/ (Markdown: https://insights.sbomify.com/GHSA-4c5f-9mj4-m247/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-4c5f-9mj4-m247

---
From sbomify Insights: https://insights.sbomify.com/GHSA-4c5f-9mj4-m247/
Summaries are generated and may contain mistakes; the official description above is the record.
