{"answers":{"affected":"2 open source packages ship an affected version, including brotkrueml/codehighlight.","exploited":"There is no known exploitation of GHSA-4cv2-xc5f-px8h in the wild and no public exploit code.","fix":"Upgrade brotkrueml/codehighlight to 2.5.0 or later.","what":"GHSA-4cv2-xc5f-px8h is a denial of service vulnerability in brotkrueml/codehighlight, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-4cv2-xc5f-px8h and fix it if it is affected.\n\nWhat it is: GHSA-4cv2-xc5f-px8h is a denial of service vulnerability in brotkrueml/codehighlight, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-4cv2-xc5f-px8h in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- brotkrueml/codehighlight (Packagist): affected all versions; fixed in 2.5.0\n- brotkrueml/codehighlight (Packagist): affected all versions; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4cv2-xc5f-px8h/ (Markdown: https://insights.sbomify.com/GHSA-4cv2-xc5f-px8h/index.md)","id":"GHSA-4cv2-xc5f-px8h","markdown":"https://insights.sbomify.com/GHSA-4cv2-xc5f-px8h/index.md","name":"GHSA-4cv2-xc5f-px8h","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Code Highlight extension","requires_auth":"none","summary":"Attackers can cause denial of service in the Code Highlight extension via ReDoS in the bundled Prism library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The codehighlight extension bundles a vulnerable version of the 3rd party JavaScript component “prism” which is known to be vulnerable against Regular expression Denial of Service (ReDoS).","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in extension \"Code Highlight\" (codehighlight)","id":"GHSA-4cv2-xc5f-px8h","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"brotkrueml/codehighlight","purl":null,"source":"GHSA-4cv2-xc5f-px8h"},{"ecosystem":"Packagist","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"brotkrueml/codehighlight","purl":"pkg:composer/brotkrueml/codehighlight","source":"GHSA-4cv2-xc5f-px8h"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in the Code Highlight extension via ReDoS in the bundled Prism library.","url":"https://insights.sbomify.com/GHSA-4cv2-xc5f-px8h/"}