{"answers":{"affected":"2 open source packages ship an affected version, including dydx-v4-client.","exploited":"There is no known exploitation of GHSA-4f84-67cv-qrv3 in the wild and no public exploit code.","fix":"Upgrade dydx-v4-client to 1.1.5 or later.","what":"GHSA-4f84-67cv-qrv3 is a vulnerability in dydx-v4-client, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-4f84-67cv-qrv3 and fix it if it is affected.\n\nWhat it is: GHSA-4f84-67cv-qrv3 is a vulnerability in dydx-v4-client, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-4f84-67cv-qrv3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dydx-v4-client (PyPI): affected from 1.1.5.post1; fixed in 1.1.5\n- dydx-v4-client (PyPI): affected from 1.1.5.post1; fixed in 1.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4f84-67cv-qrv3/ (Markdown: https://insights.sbomify.com/GHSA-4f84-67cv-qrv3/index.md)","id":"GHSA-4f84-67cv-qrv3","markdown":"https://insights.sbomify.com/GHSA-4f84-67cv-qrv3/index.md","name":"GHSA-4f84-67cv-qrv3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptocurrency client","requires_auth":"none","summary":"A compromised PyPI account uploaded a malicious version of dydx-v4-client containing an obfuscated loader that executes arbitrary code on the host.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A PyPI user account compromised by an attacker and was able to upload a malicious version (1.1.5.post1) of the `dydx-v4-client` package. This version contains a highly obfuscated multi-stage loader that ultimately executes malicious code on the host system.\n\nWhile the final payload is not visible because it is tucked away inside 100 layers of encoding, the structural design—specifically the use of recursive decompression followed by an `exec()` call is a definitive indicator of malicious software, likely a \"Crypter\" or \"Dropper\" masquerading as a cryptocurrency-related utility with the intent on connecting to hxxps://dydx[.]priceoracle[.]site/py\nto download and execute further payloads.\n\nUsers of the `dydx-v4-client` package should immediately uninstall version 1.1.5.post1and revert to the last known good version (1.1.5) or later secure versions once available. Additionally, users should monitor their systems for any unusual activity and consider running security scans to detect any potential compromise.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"A single post-release of dydx-v4-client contained obfuscated multi-stage loader","id":"GHSA-4f84-67cv-qrv3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.1.5"],"introduced":["1.1.5.post1"],"last_affected":[],"package":"dydx-v4-client","purl":null,"source":"GHSA-4f84-67cv-qrv3"},{"ecosystem":"PyPI","fixed":["1.1.5"],"introduced":["1.1.5.post1"],"last_affected":[],"package":"dydx-v4-client","purl":"pkg:pypi/dydx-v4-client","source":"GHSA-4f84-67cv-qrv3"}],"products":null,"published":"2026-02-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A compromised PyPI account uploaded a malicious version of dydx-v4-client containing an obfuscated loader that executes arbitrary code on the host.","url":"https://insights.sbomify.com/GHSA-4f84-67cv-qrv3/"}