{"answers":{"affected":"3 open source packages ship an affected version, including openssl.","exploited":"There is no known exploitation of GHSA-4fcv-w3qc-ppgg in the wild and no public exploit code.","fix":"Upgrade openssl to 0.10.72 or later.","what":"GHSA-4fcv-w3qc-ppgg is an use after free vulnerability in openssl, published on 4 Apr 2025."},"fix_prompt":"Check this codebase for GHSA-4fcv-w3qc-ppgg and fix it if it is affected.\n\nWhat it is: GHSA-4fcv-w3qc-ppgg is an use after free vulnerability in openssl, published on 4 Apr 2025. \nExploitation: There is no known exploitation of GHSA-4fcv-w3qc-ppgg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl (crates.io): affected from 0.10.39; fixed in 0.10.72\n- openssl (crates.io): affected from 0.10.39; fixed in 0.10.72\n- openssl (crates.io): affected from 0.10.39; fixed in 0.10.72\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4fcv-w3qc-ppgg/ (Markdown: https://insights.sbomify.com/GHSA-4fcv-w3qc-ppgg/index.md)","id":"GHSA-4fcv-w3qc-ppgg","markdown":"https://insights.sbomify.com/GHSA-4fcv-w3qc-ppgg/index.md","name":"GHSA-4fcv-w3qc-ppgg","record":{"aliases":["RUSTSEC-2025-0022"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust OpenSSL bindings","requires_auth":"none","summary":"A use-after-free vulnerability in rust-openssl allows attackers to potentially execute arbitrary code or cause denial of service when specific properties are passed.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"When a `Some(...)` value was passed to the `properties` argument of either of these functions, a use-after-free would result.\n\nIn practice this would nearly always result in OpenSSL treating the properties as an empty string (due to `CString::drop`'s behavior).\n\nThe maintainers thank [quitbug](https://github.com/quitbug/) for reporting this vulnerability to us.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"rust-openssl Use-After-Free in `Md::fetch` and `Cipher::fetch`","id":"GHSA-4fcv-w3qc-ppgg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"use_after_free","year":"2025"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.10.72"],"introduced":["0.10.39"],"last_affected":[],"package":"openssl","purl":null,"source":"GHSA-4fcv-w3qc-ppgg"},{"ecosystem":"crates.io","fixed":["0.10.72"],"introduced":["0.10.39"],"last_affected":[],"package":"openssl","purl":"pkg:cargo/openssl","source":"GHSA-4fcv-w3qc-ppgg"},{"ecosystem":"crates.io","fixed":["0.10.72"],"introduced":["0.10.39"],"last_affected":[],"package":"openssl","purl":"pkg:cargo/openssl","source":"RUSTSEC-2025-0022"}],"products":null,"published":"2025-04-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A use-after-free vulnerability in rust-openssl allows attackers to potentially execute arbitrary code or cause denial of service when specific properties are passed.","url":"https://insights.sbomify.com/GHSA-4fcv-w3qc-ppgg/"}