{"answers":{"affected":"2 open source packages ship an affected version, including @cubejs-backend/api-gateway.","exploited":"There is no known exploitation of GHSA-4j6x-w426-6rc6 in the wild and no public exploit code.","fix":"Upgrade @cubejs-backend/api-gateway to 0.11.17 or later.","what":"GHSA-4j6x-w426-6rc6 is a missing authorization vulnerability in @cubejs-backend/api-gateway, published on 8 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4j6x-w426-6rc6 and fix it if it is affected.\n\nWhat it is: GHSA-4j6x-w426-6rc6 is a missing authorization vulnerability in @cubejs-backend/api-gateway, published on 8 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4j6x-w426-6rc6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cubejs-backend/api-gateway (npm): affected from 0.11.0; fixed in 0.11.17\n- @cubejs-backend/api-gateway (npm): affected from 0.11.0; fixed in 0.11.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4j6x-w426-6rc6/ (Markdown: https://insights.sbomify.com/GHSA-4j6x-w426-6rc6/index.md)","id":"GHSA-4j6x-w426-6rc6","markdown":"https://insights.sbomify.com/GHSA-4j6x-w426-6rc6/index.md","name":"GHSA-4j6x-w426-6rc6","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Cube.js API gateway","requires_auth":"none","summary":"Attackers can bypass authentication in Cube.js deployments using default Express middleware in production, potentially accessing protected data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Default Express middleware security check is ignored in production\n\n### Impact\nAll Cube.js deployments that use affected versions of `@cubejs-backend/api-gateway` with default express authentication middleware in production environment are affected.\n\n### Patches\n@cubejs-backend/api-gateway@0.11.17\n\n### Workarounds\nOverride default authentication express middleware: https://cube.dev/docs/@cubejs-backend-server-core#options-reference-check-auth-middleware\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in https://github.com/cube-js/cube.js/issues\n* Reach out us in community Slack: https://slack.cube.dev/","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Default Express middleware security check is ignored in production","id":"GHSA-4j6x-w426-6rc6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.11.17"],"introduced":["0.11.0"],"last_affected":[],"package":"@cubejs-backend/api-gateway","purl":null,"source":"GHSA-4j6x-w426-6rc6"},{"ecosystem":"npm","fixed":["0.11.17"],"introduced":["0.11.0"],"last_affected":[],"package":"@cubejs-backend/api-gateway","purl":"pkg:npm/%40cubejs-backend/api-gateway","source":"GHSA-4j6x-w426-6rc6"}],"products":null,"published":"2019-11-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass authentication in Cube.js deployments using default Express middleware in production, potentially accessing protected data.","url":"https://insights.sbomify.com/GHSA-4j6x-w426-6rc6/"}