{"answers":{"affected":"2 open source packages ship an affected version, including torchserve.","exploited":"There is no known exploitation of GHSA-4mqg-h5jf-j9m7 in the wild and no public exploit code.","fix":"Upgrade torchserve to 0.8.2 or later.","what":"GHSA-4mqg-h5jf-j9m7 is an unsafe deserialization vulnerability in torchserve, published on 2 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4mqg-h5jf-j9m7 and fix it if it is affected.\n\nWhat it is: GHSA-4mqg-h5jf-j9m7 is an unsafe deserialization vulnerability in torchserve, published on 2 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4mqg-h5jf-j9m7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- torchserve (PyPI): affected from 0.3.0; fixed in 0.8.2\n- torchserve (PyPI): affected from 0.3.0; fixed in 0.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4mqg-h5jf-j9m7/ (Markdown: https://insights.sbomify.com/GHSA-4mqg-h5jf-j9m7/index.md)","id":"GHSA-4mqg-h5jf-j9m7","markdown":"https://insights.sbomify.com/GHSA-4mqg-h5jf-j9m7/index.md","name":"GHSA-4mqg-h5jf-j9m7","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TorchServe model server","requires_auth":"none","summary":"Attackers can execute arbitrary code on TorchServe servers via unsafe deserialization in the SnakeYAML library without authentication.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\n**Use of Open Source Library potentially exposed to RCE**\n    **Issue**: Use of a version of the SnakeYAML `v1.31 `open source library with multiple issues that potentially exposes the user to unsafe deserialization of Java objects. This could allow third parties to execute arbitrary code on the target system. This issue is present in versions `0.3.0` to `0.8.1`.\n    **Mitigation**: A pull request to address this issue has been merged - https://github.com/pytorch/serve/pull/2523. TorchServe release `0.8.2` includes this fix.\n\n## Patches\n\n## TorchServe release 0.8.2 includes fixes to address the previously listed issue:\n\nhttps://github.com/pytorch/serve/releases/tag/v0.8.2\n\n**Tags for upgraded DLC release**\nUser can use the following new image tags to pull DLCs that ship with patched TorchServe version 0.8.2:\nx86 GPU\n\n* v1.9-pt-ec2-2.0.1-inf-gpu-py310\n* v1.8-pt-sagemaker-2.0.1-inf-gpu-py310\n\nx86 CPU\n\n* v1.8-pt-ec2-2.0.1-inf-cpu-py310\n* v1.7-pt-sagemaker-2.0.1-inf-cpu-py310\n\nGraviton\n\n* v1.7-pt-graviton-ec2-2.0.1-inf-cpu-py310\n* v1.5-pt-graviton-sagemaker-2.0.1-inf-cpu-py310\n\nNeuron\n\n* 1.13.1-neuron-py310-sdk2.13.2-ubuntu20.04\n* 1.13.1-neuronx-py310-sdk2.13.2-ubuntu20.04\n* 1.13.1-neuronx-py310-sdk2.13.2-ubuntu20.04\n\nThe full DLC image URI details can be found at: https://github.com/aws/deep-learning-containers/blob/master/available_images.md#available-deep-learning-containers-images\n\n## References\nhttps://github.com/pytorch/serve/pull/2523\nhttps://github.com/pytorch/serve/releases/tag/v0.8.2\nhttps://github.com/aws/deep-learning-containers/blob/master/available_images.md#available-deep-learning-containers-images\n\n## Credit\nWe would like to thank Oligo Security for responsibly disclosing this issue and working with us on its resolution.\nIf you have any questions or comments about this advisory, we ask that you contact AWS/Amazon Security via our [vulnerability reporting page](https://aws.amazon.com/security/vulnerability-reporting[)](https://aws.amazon.com/security/vulnerability-reporting)) or directly via email to [aws-security@amazon.com](mailto:aws-security@amazon.com). Please do not create a public GitHub issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"TorchServe Pre-Auth Remote Code Execution","id":"GHSA-4mqg-h5jf-j9m7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.8.2"],"introduced":["0.3.0"],"last_affected":[],"package":"torchserve","purl":null,"source":"GHSA-4mqg-h5jf-j9m7"},{"ecosystem":"PyPI","fixed":["0.8.2"],"introduced":["0.3.0"],"last_affected":[],"package":"torchserve","purl":"pkg:pypi/torchserve","source":"GHSA-4mqg-h5jf-j9m7"}],"products":null,"published":"2023-10-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code on TorchServe servers via unsafe deserialization in the SnakeYAML library without authentication.","url":"https://insights.sbomify.com/GHSA-4mqg-h5jf-j9m7/"}