{"answers":{"affected":"2 open source packages ship an affected version, including dynamodb-encryption-sdk.","exploited":"There is no known exploitation of GHSA-4ph2-8337-hm62 in the wild and no public exploit code.","fix":"Upgrade dynamodb-encryption-sdk to 1.3.0 or later.","what":"GHSA-4ph2-8337-hm62 is a vulnerability in dynamodb-encryption-sdk, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4ph2-8337-hm62 and fix it if it is affected.\n\nWhat it is: GHSA-4ph2-8337-hm62 is a vulnerability in dynamodb-encryption-sdk, published on 8 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4ph2-8337-hm62 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dynamodb-encryption-sdk (PyPI): affected all versions; fixed in 1.3.0\n- dynamodb-encryption-sdk (PyPI): affected all versions; fixed in 1.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4ph2-8337-hm62/ (Markdown: https://insights.sbomify.com/GHSA-4ph2-8337-hm62/index.md)","id":"GHSA-4ph2-8337-hm62","markdown":"https://insights.sbomify.com/GHSA-4ph2-8337-hm62/index.md","name":"GHSA-4ph2-8337-hm62","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"DynamoDB Encryption Client","requires_auth":"none","summary":"Attackers can bypass key permission revocations in the DynamoDB Encryption Client by exploiting cached key usage, allowing unauthorized data access.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThis advisory concerns users of MostRecentProvider in the DynamoDB Encryption Client with a key provider like AWS Key Management Service that allows for permissions on keys to be modified.\n\nWhen key usage permissions were changed at the key provider, time-based key reauthorization logic in MostRecentProvider did not reauthorize the use of the key. This created the potential for keys to be used in the DynamoDB Encryption Client after permissions to do so were revoked at the key provider.\n\n### Patches\nFixed as of 1.3.0.  We recommend users to modify their code and adopt `CachingMostRecentProvider`.\n\n### Workarounds\nUsers who cannot upgrade to use the `CachingMostRecentProvider` can call `clear()` on the cache to manually flush all of its contents. Next use of the key will force a re-validation to occur with the key provider.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Key Caching behavior in the DynamoDB Encryption Client.","id":"GHSA-4ph2-8337-hm62","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"dynamodb-encryption-sdk","purl":null,"source":"GHSA-4ph2-8337-hm62"},{"ecosystem":"PyPI","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"dynamodb-encryption-sdk","purl":"pkg:pypi/dynamodb-encryption-sdk","source":"GHSA-4ph2-8337-hm62"}],"products":null,"published":"2021-02-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass key permission revocations in the DynamoDB Encryption Client by exploiting cached key usage, allowing unauthorized data access.","url":"https://insights.sbomify.com/GHSA-4ph2-8337-hm62/"}