{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/admin.","exploited":"There is no known exploitation of GHSA-4q66-g4mm-8rg5 in the wild and no public exploit code.","fix":"Upgrade silverstripe/admin to 1.13.6 or later.","what":"GHSA-4q66-g4mm-8rg5 is a cross-site scripting vulnerability in silverstripe/admin, published on 31 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-4q66-g4mm-8rg5 and fix it if it is affected.\n\nWhat it is: GHSA-4q66-g4mm-8rg5 is a cross-site scripting vulnerability in silverstripe/admin, published on 31 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-4q66-g4mm-8rg5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/admin (Packagist): affected all versions; fixed in 1.13.6\n- silverstripe/admin (Packagist): affected all versions; fixed in 1.13.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4q66-g4mm-8rg5/ (Markdown: https://insights.sbomify.com/GHSA-4q66-g4mm-8rg5/index.md)","id":"GHSA-4q66-g4mm-8rg5","markdown":"https://insights.sbomify.com/GHSA-4q66-g4mm-8rg5/index.md","name":"GHSA-4q66-g4mm-8rg5","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Silverstripe CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in Silverstripe CMS 4 admin interfaces via vulnerable TinyMCE components, potentially compromising user accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"TinyMCE 4.x is vulnerable to several XSS vectors, which had been patched in later versions. Two of these have been identified as affecting `silverstripe/admin`.\n\nOnly Silverstripe CMS 4 is affected by this issue. It's not possible to upgrade Silverstripe CMS 4 to use a more recent release of TinyMCE without introducing breaking changes. Instead, the security patches that shipped in later releases of TinyMCE have been backported to the TinyMCE version bundled in `silverstripe/admin`.\n\nSilverstripe CMS 5 is not affected by those vulnerabilities because it uses TinyMCE 6.\n\nYou can find more information about the underlying vulnerabilities in those GitHub security advisories:\n\n- [GHSA-5h9g-x5rv-25wg Cross-site scripting vulnerability in TinyMCE](https://github.com/advisories/GHSA-5h9g-x5rv-25wg)\n- [GHSA-w7jx-j77m-wp65 Cross-site scripting vulnerability in TinyMCE](https://github.com/advisories/GHSA-w7jx-j77m-wp65)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Silverstripe has Cross-site Scripting (XSS) vulnerabilities inherited from TinyMCE","id":"GHSA-4q66-g4mm-8rg5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"silverstripe/admin","purl":null,"source":"GHSA-4q66-g4mm-8rg5"},{"ecosystem":"Packagist","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"silverstripe/admin","purl":"pkg:composer/silverstripe/admin","source":"GHSA-4q66-g4mm-8rg5"}],"products":null,"published":"2023-07-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary scripts in Silverstripe CMS 4 admin interfaces via vulnerable TinyMCE components, potentially compromising user accounts.","url":"https://insights.sbomify.com/GHSA-4q66-g4mm-8rg5/"}