{"answers":{"affected":"2 open source packages ship an affected version, including commonmarker.","exploited":"There is no known exploitation of GHSA-4qw4-jpp4-8gvp in the wild and no public exploit code.","fix":"Upgrade commonmarker to 0.23.6 or later.","what":"GHSA-4qw4-jpp4-8gvp is a denial of service vulnerability in commonmarker, published on 21 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4qw4-jpp4-8gvp and fix it if it is affected.\n\nWhat it is: GHSA-4qw4-jpp4-8gvp is a denial of service vulnerability in commonmarker, published on 21 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4qw4-jpp4-8gvp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.6\n- commonmarker (RubyGems): affected all versions; fixed in 0.23.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4qw4-jpp4-8gvp/ (Markdown: https://insights.sbomify.com/GHSA-4qw4-jpp4-8gvp/index.md)","id":"GHSA-4qw4-jpp4-8gvp","markdown":"https://insights.sbomify.com/GHSA-4qw4-jpp4-8gvp/index.md","name":"GHSA-4qw4-jpp4-8gvp","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Markdown library","requires_auth":"none","summary":"Attackers can cause denial of service via resource exhaustion in the cmark-gfm autolink extension used by CommonMarker.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nCommonMarker uses `cmark-gfm` for rendering [Github Flavored Markdown](https://github.github.com/gfm/). A polynomial time complexity issue in cmark-gfm's autolink extension may lead to unbounded resource exhaustion and subsequent denial of service.\n\n### Patches\n\nThis vulnerability has been patched in the following CommonMarker release:\n\n- v0.23.6\n\n### Workarounds\n\nDisable use of the autolink extension.\n\n### References\n\nhttps://github.com/gjtorikian/commonmarker/pull/190\nhttps://github.com/github/cmark-gfm/security/advisories/GHSA-cgh3-p57x-9q7q\nhttps://en.wikipedia.org/wiki/Time_complexity\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [github/cmark-gfm](https://github.com/github/cmark-gfm)\n\n### Acknowledgements\n\nWe would like to thank [Legit Security](https://www.legitsecurity.com) for reporting this vulnerability.","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Unbounded resource exhaustion in cmark-gfm autolink extension may lead to denial of service","id":"GHSA-4qw4-jpp4-8gvp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["0.23.6"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":null,"source":"GHSA-4qw4-jpp4-8gvp"},{"ecosystem":"RubyGems","fixed":["0.23.6"],"introduced":["0"],"last_affected":[],"package":"commonmarker","purl":"pkg:gem/commonmarker","source":"GHSA-4qw4-jpp4-8gvp"}],"products":null,"published":"2022-09-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service via resource exhaustion in the cmark-gfm autolink extension used by CommonMarker.","url":"https://insights.sbomify.com/GHSA-4qw4-jpp4-8gvp/"}