{"answers":{"affected":"2 open source packages ship an affected version, including constantinople.","exploited":"There is no known exploitation of GHSA-4vmm-mhcq-4x9j in the wild and no public exploit code.","fix":"Upgrade constantinople to 3.1.1 or later.","what":"GHSA-4vmm-mhcq-4x9j is a code injection vulnerability in constantinople, published on 14 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4vmm-mhcq-4x9j and fix it if it is affected.\n\nWhat it is: GHSA-4vmm-mhcq-4x9j is a code injection vulnerability in constantinople, published on 14 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4vmm-mhcq-4x9j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- constantinople (npm): affected all versions; fixed in 3.1.1\n- constantinople (npm): affected all versions; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4vmm-mhcq-4x9j/ (Markdown: https://insights.sbomify.com/GHSA-4vmm-mhcq-4x9j/index.md)","id":"GHSA-4vmm-mhcq-4x9j","markdown":"https://insights.sbomify.com/GHSA-4vmm-mhcq-4x9j/index.md","name":"GHSA-4vmm-mhcq-4x9j","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript template library","requires_auth":"none","summary":"An attacker can bypass the sandbox in the constantinople library to execute arbitrary code on the host system.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `constantinople` prior to 3.1.1 are vulnerable to a sandbox bypass which can lead to arbitrary code execution.\n\n## Recommendation\n\nUpdate to version 3.1.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Sandbox Bypass Leading to Arbitrary Code Execution in constantinople","id":"GHSA-4vmm-mhcq-4x9j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"constantinople","purl":null,"source":"GHSA-4vmm-mhcq-4x9j"},{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"constantinople","purl":"pkg:npm/constantinople","source":"GHSA-4vmm-mhcq-4x9j"}],"products":null,"published":"2019-06-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can bypass the sandbox in the constantinople library to execute arbitrary code on the host system.","url":"https://insights.sbomify.com/GHSA-4vmm-mhcq-4x9j/"}