{"answers":{"affected":"2 open source packages ship an affected version, including Gw2Sharp.","exploited":"There is no known exploitation of GHSA-4vr3-9v7h-5f8v in the wild and no public exploit code.","fix":"Upgrade Gw2Sharp to 0.3.1 or later.","what":"GHSA-4vr3-9v7h-5f8v is a vulnerability in Gw2Sharp, published on 18 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4vr3-9v7h-5f8v and fix it if it is affected.\n\nWhat it is: GHSA-4vr3-9v7h-5f8v is a vulnerability in Gw2Sharp, published on 18 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4vr3-9v7h-5f8v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Gw2Sharp (NuGet): affected all versions; fixed in 0.3.1\n- Gw2Sharp (NuGet): affected all versions; fixed in 0.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4vr3-9v7h-5f8v/ (Markdown: https://insights.sbomify.com/GHSA-4vr3-9v7h-5f8v/index.md)","id":"GHSA-4vr3-9v7h-5f8v","markdown":"https://insights.sbomify.com/GHSA-4vr3-9v7h-5f8v/index.md","name":"GHSA-4vr3-9v7h-5f8v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Guild Wars 2 API library","requires_auth":"low_privilege","summary":"Cached authenticated responses may leak data between users sharing a cache instance, requiring specific client configuration to exploit.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Leaking cached authenticated requests\n\n### Impact\nIf you've been using one `MemoryCacheMethod` object in multiple instances of `Gw2WebApiClient` and are requesting authenticated endpoints with different access tokens, then you are likely to run into this bug.\n\nWhen using an instance of `MemoryCacheMethod` and using it with multiple instances of `Gw2WebApiClient`, there's a possibility that cached authenticated responses are leaking to another request to the same endpoint, but with a different Guild Wars 2 access token. The latter request wouldn't start however, and would return the first cached response immediately. This means that the second response (or later responses) may contain the same data as the first response, therefore leaking data from another authenticated endpoint.\n\nThe occurence of this is limited however. The Guild Wars 2 API doesn't use the `Expires` header on most (if not all) authenticated endpoints. This header is checked when caching responses. If this header isn't available, the response isn't cached at all. You should still update to at least version 0.3.1 in order to be certain that it won't happen.\n\n### Patches\nThis bug has been fixed in version 0.3.1. When using an authenticated endpoint, it will prepend the SHA-1 hash of the access token to the cache id.\n\n### Workarounds\nFor version 0.3.0 and lower, you can use one separate instance of `MemoryCacheMethod` per `Gw2WebApiClient` if you need to use it.\n\n### For more information\nIf you have any questions or comments about this advisory, you can open an issue in [the Gw2Sharp repository](https://github.com/Archomeda/Gw2Sharp) or contact me on [Discord](https://discord.gg/hNcpDT3).","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Low severity vulnerability that affects Gw2Sharp","id":"GHSA-4vr3-9v7h-5f8v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["0.3.1"],"introduced":["0"],"last_affected":[],"package":"Gw2Sharp","purl":null,"source":"GHSA-4vr3-9v7h-5f8v"},{"ecosystem":"NuGet","fixed":["0.3.1"],"introduced":["0"],"last_affected":[],"package":"Gw2Sharp","purl":"pkg:nuget/Gw2Sharp","source":"GHSA-4vr3-9v7h-5f8v"}],"products":null,"published":"2019-06-18","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Cached authenticated responses may leak data between users sharing a cache instance, requiring specific client configuration to exploit.","url":"https://insights.sbomify.com/GHSA-4vr3-9v7h-5f8v/"}