# GHSA-4x48-cgf9-q33f: Novu has SSRF via conditions filter webhook bypasses validateUrlSsrf() protection

> Attackers can exploit SSRF in Novu's conditions filter webhook to read sensitive internal data, including cloud credentials, by bypassing URL validation.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026

## What is GHSA-4x48-cgf9-q33f?

GHSA-4x48-cgf9-q33f is a server-side request forgery vulnerability in @novu/api, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

## Summary

The conditions filter webhook at `libs/application-generic/src/usecases/conditions-filter/conditions-filter.usecase.ts` line 261 sends POST requests to user-configured URLs using raw `axios.post()` with no SSRF validation. The HTTP Request workflow step in the same codebase correctly uses `validateUrlSsrf()` which blocks private IP ranges. The conditions webhook was not included in this protection.

## Root Cause

`conditions-filter.usecase.ts` line 261:
```typescript
return await axios.post(child.webhookUrl, payload, config).then((response) => {
  return response.data as Record<string, unknown>;
});
```

No call to `validateUrlSsrf()`. The `webhookUrl` comes from the workflow condition configuration with zero validation.

## Protected Code (for contrast)

`execute-http-request-step.usecase.ts` line 130:
```typescript
const ssrfValidationError = await validateUrlSsrf(url);
if (ssrfValidationError) {
  // blocked
}
```

This function resolves DNS and checks against private ranges (127.0.0.0/8, 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16, 169.254.0.0/16). It exists in the codebase but is not applied to the conditions webhook path.

## Proof of Concept

1. Create a workflow with a condition step
2. Configure the condition's webhook URL to `http://169.254.169.254/latest/meta-data/iam/security-credentials/`
3. Trigger the workflow by sending a notification event
4. The worker evaluates the condition and calls `axios.post()` to the metadata endpoint
5. The response data is stored in execution details and accessible via the execution details API

## Impact

Full-read SSRF. The response body is returned as `Record<string, unknown>` for condition evaluation and stored in the execution details `raw` field. The `GET /execution-details` API returns this data.

The POST method limits some metadata endpoints (GCP requires GET, Azure requires GET), but AWS IMDSv1 accepts POST and returns credentials. Internal services accepting POST are also reachable.

## Suggested Fix

Extract `validateUrlSsrf()` to a shared utility and call it before the axios.post in conditions-filter.usecase.ts:

```typescript
const ssrfError = await validateUrlSsrf(child.webhookUrl);
if (ssrfError) {
  throw new Error('Webhook URL blocked by SSRF protection');
}
return await axios.post(child.webhookUrl, payload, config)...
```

## Which versions are affected by GHSA-4x48-cgf9-q33f?

2 open source packages ship an affected version, including @novu/api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@novu/api` | npm | All versions | 3.15.0 |
| `@novu/api` | npm | All versions | 3.15.0 |

## How do I fix GHSA-4x48-cgf9-q33f?

Upgrade @novu/api to 3.15.0 or later.

## Is GHSA-4x48-cgf9-q33f being exploited?

There is no known exploitation of GHSA-4x48-cgf9-q33f in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-4x48-cgf9-q33f and fix it if it is affected.

What it is: GHSA-4x48-cgf9-q33f is a server-side request forgery vulnerability in @novu/api, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-4x48-cgf9-q33f in the wild and no public exploit code.

Affected packages and fixed versions:
- @novu/api (npm): affected all versions; fixed in 3.15.0
- @novu/api (npm): affected all versions; fixed in 3.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-4x48-cgf9-q33f/ (Markdown: https://insights.sbomify.com/GHSA-4x48-cgf9-q33f/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-4x48-cgf9-q33f

---
From sbomify Insights: https://insights.sbomify.com/GHSA-4x48-cgf9-q33f/
Summaries are generated and may contain mistakes; the official description above is the record.
