{"answers":{"affected":"2 open source packages ship an affected version, including mem.","exploited":"There is no known exploitation of GHSA-4xcv-9jjx-gfj3 in the wild and no public exploit code.","fix":"Upgrade mem to 4.0.0 or later.","what":"GHSA-4xcv-9jjx-gfj3 is a denial of service vulnerability in mem, published on 5 Jul 2019. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4xcv-9jjx-gfj3 and fix it if it is affected.\n\nWhat it is: GHSA-4xcv-9jjx-gfj3 is a denial of service vulnerability in mem, published on 5 Jul 2019. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4xcv-9jjx-gfj3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mem (npm): affected all versions; fixed in 4.0.0\n- mem (npm): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4xcv-9jjx-gfj3/ (Markdown: https://insights.sbomify.com/GHSA-4xcv-9jjx-gfj3/index.md)","id":"GHSA-4xcv-9jjx-gfj3","markdown":"https://insights.sbomify.com/GHSA-4xcv-9jjx-gfj3/index.md","name":"GHSA-4xcv-9jjx-gfj3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js caching library","requires_auth":"unknown","summary":"Attackers can exhaust system memory by abusing application logging due to a cache cleanup failure in the mem library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `mem` prior to 4.0.0 are vulnerable to Denial of Service (DoS).  The package fails to remove old values from the cache even after a value passes its `maxAge` property. This may allow attackers to exhaust the system's memory if they are able to abuse the application logging.\n\n## Recommendation\n\nUpgrade to version 4.0.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in mem","id":"GHSA-4xcv-9jjx-gfj3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"mem","purl":null,"source":"GHSA-4xcv-9jjx-gfj3"},{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"mem","purl":"pkg:npm/mem","source":"GHSA-4xcv-9jjx-gfj3"}],"products":null,"published":"2019-07-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exhaust system memory by abusing application logging due to a cache cleanup failure in the mem library.","url":"https://insights.sbomify.com/GHSA-4xcv-9jjx-gfj3/"}