{"answers":{"affected":"5 open source packages ship an affected version, including github.com/pion/dtls/v2 and github.com/pion/dtls.","exploited":"There is no known exploitation of GHSA-4xgv-j62q-h3rj in the wild and no public exploit code.","fix":"Upgrade github.com/pion/dtls/v2 to 2.2.4 or later.","what":"GHSA-4xgv-j62q-h3rj is a denial of service vulnerability in github.com/pion/dtls, published on 7 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-4xgv-j62q-h3rj and fix it if it is affected.\n\nWhat it is: GHSA-4xgv-j62q-h3rj is a denial of service vulnerability in github.com/pion/dtls, published on 7 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-4xgv-j62q-h3rj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pion/dtls/v2 (Go): affected all versions; fixed in 2.2.4\n- github.com/pion/dtls/v2 (Go): affected all versions; fixed in 2.2.4\n- github.com/pion/dtls/v2 (Go): affected all versions; fixed in 2.2.4\n- github.com/pion/dtls (Go): affected all versions up to 1.5.4; no fix listed\n- github.com/pion/dtls (Go): affected all versions up to 1.5.4; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-4xgv-j62q-h3rj/ (Markdown: https://insights.sbomify.com/GHSA-4xgv-j62q-h3rj/index.md)","id":"GHSA-4xgv-j62q-h3rj","markdown":"https://insights.sbomify.com/GHSA-4xgv-j62q-h3rj/index.md","name":"GHSA-4xgv-j62q-h3rj","record":{"aliases":["GO-2023-1534"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go DTLS library","requires_auth":"none","summary":"A remote attacker can crash the application by sending a malformed Hello Verify Request, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nDuring the unmarshalling of a hello verify request we could try to unmarshal into too small a buffer. is could result in a panic leading the program to crash.\n\nThis issue could be abused to cause a denial of service.\n\n### Workaround\n\nNone, upgrade to 2.2.4","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Panic during unmarshal of Hello Verify Request in github.com/pion/dtls/v2","id":"GHSA-4xgv-j62q-h3rj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":5,"n_references":null,"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["1.5.4"],"package":"github.com/pion/dtls","purl":null,"source":"GHSA-4xgv-j62q-h3rj"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["1.5.4"],"package":"github.com/pion/dtls","purl":"pkg:golang/github.com/pion/dtls","source":"GHSA-4xgv-j62q-h3rj"},{"ecosystem":"Go","fixed":["2.2.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pion/dtls/v2","purl":null,"source":"GHSA-4xgv-j62q-h3rj"},{"ecosystem":"Go","fixed":["2.2.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pion/dtls/v2","purl":"pkg:golang/github.com/pion/dtls/v2","source":"GHSA-4xgv-j62q-h3rj"},{"ecosystem":"Go","fixed":["2.2.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pion/dtls/v2","purl":"pkg:golang/github.com/pion/dtls/v2","source":"GO-2023-1534"}],"products":null,"published":"2023-02-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A remote attacker can crash the application by sending a malformed Hello Verify Request, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-4xgv-j62q-h3rj/"}