GHSA-537c-gmf6-5ccf Vulnerable OpenSSL included in cryptography wheels
Vulnerable OpenSSL in cryptography wheels allows exploitation of underlying OpenSSL flaws; users must upgrade the library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-537c-gmf6-5ccf?
GHSA-537c-gmf6-5ccf is a vulnerability in cryptography, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20260609.txt.
If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Which versions are affected by GHSA-537c-gmf6-5ccf?
2 open source packages ship an affected version, including cryptography.
| Package | Affected | Fixed in |
|---|---|---|
cryptography PyPI | From 0.5.0 | 48.0.1 |
cryptography PyPI | From 0.5.0 | 48.0.1 |
How do I fix GHSA-537c-gmf6-5ccf?
Upgrade cryptography to 48.0.1 or later.
Is GHSA-537c-gmf6-5ccf being exploited?
There is no known exploitation of GHSA-537c-gmf6-5ccf in the wild and no public exploit code.