{"answers":{"affected":"2 open source packages ship an affected version, including cryptography.","exploited":"There is no known exploitation of GHSA-537c-gmf6-5ccf in the wild and no public exploit code.","fix":"Upgrade cryptography to 48.0.1 or later.","what":"GHSA-537c-gmf6-5ccf is a vulnerability in cryptography, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-537c-gmf6-5ccf and fix it if it is affected.\n\nWhat it is: GHSA-537c-gmf6-5ccf is a vulnerability in cryptography, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-537c-gmf6-5ccf in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cryptography (PyPI): affected from 0.5.0; fixed in 48.0.1\n- cryptography (PyPI): affected from 0.5.0; fixed in 48.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-537c-gmf6-5ccf/ (Markdown: https://insights.sbomify.com/GHSA-537c-gmf6-5ccf/index.md)","id":"GHSA-537c-gmf6-5ccf","markdown":"https://insights.sbomify.com/GHSA-537c-gmf6-5ccf/index.md","name":"GHSA-537c-gmf6-5ccf","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"Vulnerable OpenSSL in cryptography wheels allows exploitation of underlying OpenSSL flaws; users must upgrade the library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20260609.txt.\n\nIf you are building cryptography source (\"sdist\") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Vulnerable OpenSSL included in cryptography wheels","id":"GHSA-537c-gmf6-5ccf","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["48.0.1"],"introduced":["0.5.0"],"last_affected":[],"package":"cryptography","purl":null,"source":"GHSA-537c-gmf6-5ccf"},{"ecosystem":"PyPI","fixed":["48.0.1"],"introduced":["0.5.0"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"GHSA-537c-gmf6-5ccf"}],"products":null,"published":"2026-06-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Vulnerable OpenSSL in cryptography wheels allows exploitation of underlying OpenSSL flaws; users must upgrade the library.","url":"https://insights.sbomify.com/GHSA-537c-gmf6-5ccf/"}