# GHSA-537c-gmf6-5ccf: Vulnerable OpenSSL included in cryptography wheels

> Vulnerable OpenSSL in cryptography wheels allows exploitation of underlying OpenSSL flaws; users must upgrade the library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026

## What is GHSA-537c-gmf6-5ccf?

GHSA-537c-gmf6-5ccf is a vulnerability in cryptography, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20260609.txt.

If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

## Which versions are affected by GHSA-537c-gmf6-5ccf?

2 open source packages ship an affected version, including cryptography.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | From 0.5.0 | 48.0.1 |
| `cryptography` | PyPI | From 0.5.0 | 48.0.1 |

## How do I fix GHSA-537c-gmf6-5ccf?

Upgrade cryptography to 48.0.1 or later.

## Is GHSA-537c-gmf6-5ccf being exploited?

There is no known exploitation of GHSA-537c-gmf6-5ccf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-537c-gmf6-5ccf and fix it if it is affected.

What it is: GHSA-537c-gmf6-5ccf is a vulnerability in cryptography, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-537c-gmf6-5ccf in the wild and no public exploit code.

Affected packages and fixed versions:
- cryptography (PyPI): affected from 0.5.0; fixed in 48.0.1
- cryptography (PyPI): affected from 0.5.0; fixed in 48.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-537c-gmf6-5ccf/ (Markdown: https://insights.sbomify.com/GHSA-537c-gmf6-5ccf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-537c-gmf6-5ccf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-537c-gmf6-5ccf/
Summaries are generated and may contain mistakes; the official description above is the record.
