# GHSA-5423-jcjm-2gpv: Traefik affected by Go HTTP Request Smuggling Vulnerability

> Traefik is vulnerable to HTTP request smuggling via invalid chunked data, allowing attackers to bypass security controls or access sensitive data.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2025
- **Also known as:** GO-2025-3627

## What is GHSA-5423-jcjm-2gpv?

GHSA-5423-jcjm-2gpv is a vulnerability in github.com/traefik/traefik, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
net/http: request smuggling through invalid chunked data: The net/http package accepts data in the chunked transfer encoding containing an invalid chunk-size line terminated by a bare LF. When used in conjunction with a server or proxy which incorrectly interprets a bare LF in a chunk extension as part of the extension, this could permit request smuggling. [CVE-2025-22871] Vendor Affected Components: Go: 1.23.x < 1.23.8

More Details: [CVE-2025-22871](https://nvd.nist.gov/vuln/detail/CVE-2025-22871)

## Patches

- https://github.com/traefik/traefik/releases/tag/v2.11.24
- https://github.com/traefik/traefik/releases/tag/v3.3.6
- https://github.com/traefik/traefik/releases/tag/v3.4.0-rc2

## Which versions are affected by GHSA-5423-jcjm-2gpv?

9 open source packages ship an affected version, including github.com/traefik/traefik/v3, github.com/traefik/traefik and github.com/traefik/traefik/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.3.6, 3.4.0-rc2 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.3.6 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.3.6 |
| `github.com/traefik/traefik/v3` | Go | From 3.4.0-rc1 | 3.4.0-rc2 |
| `github.com/traefik/traefik/v3` | Go | From 3.4.0-rc1 | 3.4.0-rc2 |
| `github.com/traefik/traefik` | Go | All versions | None |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.24 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.24 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.24 |

## How do I fix GHSA-5423-jcjm-2gpv?

Upgrade github.com/traefik/traefik/v3 to a fixed version for your release line: 3.3.6 or 3.4.0-rc2.

## Is GHSA-5423-jcjm-2gpv being exploited?

There is no known exploitation of GHSA-5423-jcjm-2gpv in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5423-jcjm-2gpv and fix it if it is affected.

What it is: GHSA-5423-jcjm-2gpv is a vulnerability in github.com/traefik/traefik, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5423-jcjm-2gpv in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.3.6, 3.4.0-rc2
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.3.6
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.3.6
- github.com/traefik/traefik/v3 (Go): affected from 3.4.0-rc1; fixed in 3.4.0-rc2
- github.com/traefik/traefik/v3 (Go): affected from 3.4.0-rc1; fixed in 3.4.0-rc2
- github.com/traefik/traefik (Go): affected all versions; no fix listed
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.24
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.24
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5423-jcjm-2gpv/ (Markdown: https://insights.sbomify.com/GHSA-5423-jcjm-2gpv/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5423-jcjm-2gpv

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5423-jcjm-2gpv/
Summaries are generated and may contain mistakes; the official description above is the record.
