{"answers":{"affected":"2 open source packages ship an affected version, including intercom-client.","exploited":"There is no known exploitation of GHSA-54pg-9963-v8vg in the wild and no public exploit code.","fix":"No fix has been published for GHSA-54pg-9963-v8vg yet. Limit exposure of the affected software until one is available.","what":"GHSA-54pg-9963-v8vg is a vulnerability in intercom-client, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-54pg-9963-v8vg and fix it if it is affected.\n\nWhat it is: GHSA-54pg-9963-v8vg is a vulnerability in intercom-client, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-54pg-9963-v8vg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- intercom-client (npm): affected all versions; no fix listed\n- intercom-client (npm): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-54pg-9963-v8vg/ (Markdown: https://insights.sbomify.com/GHSA-54pg-9963-v8vg/index.md)","id":"GHSA-54pg-9963-v8vg","markdown":"https://insights.sbomify.com/GHSA-54pg-9963-v8vg/index.md","name":"GHSA-54pg-9963-v8vg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"npm client library","requires_auth":"none","summary":"A compromised npm package version executes malicious code during installation, stealing credentials and environment data from developer machines and CI systems.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nOn April 30, 2026, version 7.0.4 of intercom-client was published to npm using credentials obtained from a compromised developer account. This version was not produced by Intercom's build pipeline.\n\nThe malicious version contained an obfuscated JavaScript payload that executed during package installation via a preinstall hook. The payload harvested credentials from the environment in which it ran, including cloud provider credentials (AWS, GCP, Azure), environment variables, .env files, GitHub and npm tokens, SSH keys, local configuration files, and cloud metadata service credentials.\n\nHarvested data was exfiltrated to attacker-controlled GitHub repositories. The package was live on npm for approximately 2 hours (15:00-17:00 UTC).\n\nThis compromise is part of the \"Mini Shai-Hulud\" supply chain campaign tracked by Wiz and Socket.\n\nDevelopers can check if their projects are affected by running: `npm list intercom-client`. If it shows 7.0.4, the project is affected.\n\n### Patches\n\nVersion 7.0.3 and all prior versions are unaffected. Downgrade to 7.0.3 immediately.\n\n### Workarounds\n\nIf a developer installed version 7.0.4 on any machine or CI system, treat all credentials accessible from that environment as compromised and rotate them. Check lock files (`package-lock.json`, `yarn.lock`, `pnpm-lock.yaml`) for references to 7.0.4. Review CI/CD build logs for any `npm install` that resolved to 7.0.4 between 15:00 and 17:00 UTC on April 30, 2026.\n\n### Resources\n\n- https://socket.dev/blog/intercom-s-npm-package-compromised-in-supply-chain-attack\n- https://www.intercomstatus.com/us-hosting/incidents/01KQFN6VS6ARP1XBR1K1SBYY59\n- https://www.wiz.io/blog/mini-shai-hulud-supply-chain-sap-npm","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"Compromised version of intercom-client published to npm","id":"GHSA-54pg-9963-v8vg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":[],"introduced":[],"last_affected":[],"package":"intercom-client","purl":null,"source":"GHSA-54pg-9963-v8vg"},{"ecosystem":"npm","fixed":[],"introduced":[],"last_affected":[],"package":"intercom-client","purl":"pkg:npm/intercom-client","source":"GHSA-54pg-9963-v8vg"}],"products":null,"published":"2026-05-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A compromised npm package version executes malicious code during installation, stealing credentials and environment data from developer machines and CI systems.","url":"https://insights.sbomify.com/GHSA-54pg-9963-v8vg/"}