{"answers":{"affected":"2 open source packages ship an affected version, including wallabag/wallabag.","exploited":"There is no known exploitation of GHSA-56fm-hfp3-x3w3 in the wild and no public exploit code.","fix":"Upgrade wallabag/wallabag to 2.6.7 or later.","what":"GHSA-56fm-hfp3-x3w3 is a vulnerability in wallabag/wallabag, published on 2 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-56fm-hfp3-x3w3 and fix it if it is affected.\n\nWhat it is: GHSA-56fm-hfp3-x3w3 is a vulnerability in wallabag/wallabag, published on 2 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-56fm-hfp3-x3w3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wallabag/wallabag (Packagist): affected from 2.0.0-alpha.1; fixed in 2.6.7\n- wallabag/wallabag (Packagist): affected from 2.0.0-alpha.1; fixed in 2.6.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-56fm-hfp3-x3w3/ (Markdown: https://insights.sbomify.com/GHSA-56fm-hfp3-x3w3/index.md)","id":"GHSA-56fm-hfp3-x3w3","markdown":"https://insights.sbomify.com/GHSA-56fm-hfp3-x3w3/index.md","name":"GHSA-56fm-hfp3-x3w3","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Wallabag self-hosted app","requires_auth":"low_privilege","summary":"Attackers can force authenticated users to disable two-factor authentication via CSRF, reducing account security.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\nwallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily disable 2FA through `/config/otp/app/disable` and `/config/otp/email/disable`.\n\nThis vulnerability has a CVSSv3.1 score of 4.3.\n\n**You should upgrade your instance to version 2.6.7 or higher.**\n\n## Resolution\n\nThese endpoints now require POST method.\n\n## Credits\n\nWe would like to thank @dhina016 for reporting this issue through huntr.dev.\n\nReference: https://huntr.dev/bounties/4c446fe7-2a44-4907-b0cf-4ab77d75c487/","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Wallabag user can disable 2FA unintentionally","id":"GHSA-56fm-hfp3-x3w3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.6.7"],"introduced":["2.0.0-alpha.1"],"last_affected":[],"package":"wallabag/wallabag","purl":null,"source":"GHSA-56fm-hfp3-x3w3"},{"ecosystem":"Packagist","fixed":["2.6.7"],"introduced":["2.0.0-alpha.1"],"last_affected":[],"package":"wallabag/wallabag","purl":"pkg:composer/wallabag/wallabag","source":"GHSA-56fm-hfp3-x3w3"}],"products":null,"published":"2023-10-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can force authenticated users to disable two-factor authentication via CSRF, reducing account security.","url":"https://insights.sbomify.com/GHSA-56fm-hfp3-x3w3/"}