# GHSA-56fm-hfp3-x3w3: Wallabag user can disable 2FA unintentionally

> Attackers can force authenticated users to disable two-factor authentication via CSRF, reducing account security.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Oct 2023

## What is GHSA-56fm-hfp3-x3w3?

GHSA-56fm-hfp3-x3w3 is a vulnerability in wallabag/wallabag, published on 2 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

## Impact
wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily disable 2FA through `/config/otp/app/disable` and `/config/otp/email/disable`.

This vulnerability has a CVSSv3.1 score of 4.3.

**You should upgrade your instance to version 2.6.7 or higher.**

## Resolution

These endpoints now require POST method.

## Credits

We would like to thank @dhina016 for reporting this issue through huntr.dev.

Reference: https://huntr.dev/bounties/4c446fe7-2a44-4907-b0cf-4ab77d75c487/

## Which versions are affected by GHSA-56fm-hfp3-x3w3?

2 open source packages ship an affected version, including wallabag/wallabag.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wallabag/wallabag` | Packagist | From 2.0.0-alpha.1 | 2.6.7 |
| `wallabag/wallabag` | Packagist | From 2.0.0-alpha.1 | 2.6.7 |

## How do I fix GHSA-56fm-hfp3-x3w3?

Upgrade wallabag/wallabag to 2.6.7 or later.

## Is GHSA-56fm-hfp3-x3w3 being exploited?

There is no known exploitation of GHSA-56fm-hfp3-x3w3 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-56fm-hfp3-x3w3 and fix it if it is affected.

What it is: GHSA-56fm-hfp3-x3w3 is a vulnerability in wallabag/wallabag, published on 2 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-56fm-hfp3-x3w3 in the wild and no public exploit code.

Affected packages and fixed versions:
- wallabag/wallabag (Packagist): affected from 2.0.0-alpha.1; fixed in 2.6.7
- wallabag/wallabag (Packagist): affected from 2.0.0-alpha.1; fixed in 2.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-56fm-hfp3-x3w3/ (Markdown: https://insights.sbomify.com/GHSA-56fm-hfp3-x3w3/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-56fm-hfp3-x3w3

---
From sbomify Insights: https://insights.sbomify.com/GHSA-56fm-hfp3-x3w3/
Summaries are generated and may contain mistakes; the official description above is the record.
