{"answers":{"affected":"2 open source packages ship an affected version, including npmconf.","exploited":"There is no known exploitation of GHSA-57cf-349j-352g in the wild and no public exploit code.","fix":"Upgrade npmconf to 2.1.3 or later.","what":"GHSA-57cf-349j-352g is a vulnerability in npmconf, published on 12 Jun 2019."},"fix_prompt":"Check this codebase for GHSA-57cf-349j-352g and fix it if it is affected.\n\nWhat it is: GHSA-57cf-349j-352g is a vulnerability in npmconf, published on 12 Jun 2019. \nExploitation: There is no known exploitation of GHSA-57cf-349j-352g in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- npmconf (npm): affected all versions; fixed in 2.1.3\n- npmconf (npm): affected all versions; fixed in 2.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-57cf-349j-352g/ (Markdown: https://insights.sbomify.com/GHSA-57cf-349j-352g/index.md)","id":"GHSA-57cf-349j-352g","markdown":"https://insights.sbomify.com/GHSA-57cf-349j-352g/index.md","name":"GHSA-57cf-349j-352g","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"unknown","non_default_config":false,"product_category":"npm configuration library","requires_auth":"none","summary":"An out-of-bounds read in npmconf allows attackers to disclose uninitialized memory contents when processing typed numbers on Node.js 4.x.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `npmconf` before 2.1.3 allocate and write to disk uninitialized memory contents when a typed number is passed as input on Node.js 4.x.\n\n## Recommendation\n\nUpdate to version 2.1.3 or later. Consider switching to another config storage mechanism, as npmconf is deprecated and should not be used.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Out-of-bounds Read in npmconf","id":"GHSA-57cf-349j-352g","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.1.3"],"introduced":["0"],"last_affected":[],"package":"npmconf","purl":null,"source":"GHSA-57cf-349j-352g"},{"ecosystem":"npm","fixed":["2.1.3"],"introduced":["0"],"last_affected":[],"package":"npmconf","purl":"pkg:npm/npmconf","source":"GHSA-57cf-349j-352g"}],"products":null,"published":"2019-06-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An out-of-bounds read in npmconf allows attackers to disclose uninitialized memory contents when processing typed numbers on Node.js 4.x.","url":"https://insights.sbomify.com/GHSA-57cf-349j-352g/"}