{"answers":{"affected":"4 open source packages ship an affected version, including pterodactyl/panel.","exploited":"There is no known exploitation of GHSA-5822-pw57-vv37 in the wild and no public exploit code.","fix":"Upgrade pterodactyl/panel to a fixed version for your release line: 0.7.19 or 1.0.0-rc.7.","what":"GHSA-5822-pw57-vv37 is a cross-site scripting vulnerability in pterodactyl/panel, published on 8 Oct 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-5822-pw57-vv37 and fix it if it is affected.\n\nWhat it is: GHSA-5822-pw57-vv37 is a cross-site scripting vulnerability in pterodactyl/panel, published on 8 Oct 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-5822-pw57-vv37 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pterodactyl/panel (Packagist): affected all versions; fixed in 0.7.19\n- pterodactyl/panel (Packagist): affected all versions; fixed in 0.7.19\n- pterodactyl/panel (Packagist): affected from 1.0.0-rc.0; fixed in 1.0.0-rc.7\n- pterodactyl/panel (Packagist): affected from 1.0.0-rc.0; fixed in 1.0.0-rc.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5822-pw57-vv37/ (Markdown: https://insights.sbomify.com/GHSA-5822-pw57-vv37/index.md)","id":"GHSA-5822-pw57-vv37","markdown":"https://insights.sbomify.com/GHSA-5822-pw57-vv37/index.md","name":"GHSA-5822-pw57-vv37","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Game server panel","requires_auth":"high_privilege","summary":"An XSS vulnerability in Pterodactyl Panel allows attackers to inject scripts via account names in admin server pages, potentially compromising admin accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nAn XSS vulnerability exists in versions of Pterodactyl Panel before 0.7.19. Affected versions do not properly sanitize account names before rendering them to the dropdown selector in the admin area when creating or modifying a server.\n\n### Patches\nThis XSS has been addressed in 0.7.19 and will be rolled forwards into the 1.0-rc.7 release.\n\n### Workarounds\nNo workaround exists without manual patching. See https://github.com/pterodactyl/panel/pull/2441/files for the files changed.\n\n### For more information\nIf you have any questions or comments about this advisory please reach out on Discord, or by emailing `dane` at `pterodactyl` dot `io`.\n\n_Thank you to Sergej for the responsible disclosure of this issue._","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"XSS vulnerability when listing users on add \u0026 modify server pages.","id":"GHSA-5822-pw57-vv37","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["0.7.19"],"introduced":["0"],"last_affected":[],"package":"pterodactyl/panel","purl":null,"source":"GHSA-5822-pw57-vv37"},{"ecosystem":"Packagist","fixed":["0.7.19"],"introduced":["0"],"last_affected":[],"package":"pterodactyl/panel","purl":"pkg:composer/pterodactyl/panel","source":"GHSA-5822-pw57-vv37"},{"ecosystem":"Packagist","fixed":["1.0.0-rc.7"],"introduced":["1.0.0-rc.0"],"last_affected":[],"package":"pterodactyl/panel","purl":null,"source":"GHSA-5822-pw57-vv37"},{"ecosystem":"Packagist","fixed":["1.0.0-rc.7"],"introduced":["1.0.0-rc.0"],"last_affected":[],"package":"pterodactyl/panel","purl":"pkg:composer/pterodactyl/panel","source":"GHSA-5822-pw57-vv37"}],"products":null,"published":"2020-10-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XSS vulnerability in Pterodactyl Panel allows attackers to inject scripts via account names in admin server pages, potentially compromising admin accounts.","url":"https://insights.sbomify.com/GHSA-5822-pw57-vv37/"}