# GHSA-5847-rm3g-23mw: OpenClaw has hook auth rate limiter bypass via IPv4-mapped IPv6 client key variants

> Attackers can bypass hook authentication rate limits by using IPv4-mapped IPv6 addresses, doubling brute-force attempts.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2026

## What is GHSA-5847-rm3g-23mw?

GHSA-5847-rm3g-23mw is a vulnerability in openclaw, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

## Vulnerability

The hook authentication throttle keyed failed attempts by raw socket `remoteAddress` text.

IPv4 and IPv4-mapped IPv6 forms of the same client (for example `1.2.3.4` and `::ffff:1.2.3.4`) were treated as different clients, allowing separate rate-limit buckets.

## Impact

An attacker could split failed hook-auth attempts across both address forms and effectively double the brute-force budget from 20 to 40 attempts per 60-second window.

## Affected Components

- `src/gateway/server-http.ts`
- `src/gateway/auth-rate-limit.ts`

## Affected Packages / Versions

- Package: `openclaw` (npm)
- Vulnerable versions: `<= 2026.2.21-2`
- Patched version (planned next release): `2026.2.22`

## Remediation

Centralize and reuse canonical client-IP normalization for auth rate-limiting, and use that canonical key for hook auth throttling.

## Fix Commit(s)

- `3284d2eb227e7b6536d543bcf5c3e320bc9d13c5`

## Release Process Note

`patched_versions` is pre-set to the planned next release (`2026.2.22`) so once npm release `2026.2.22` is published, this advisory can be published directly.

OpenClaw thanks @aether-ai-agent for reporting.

## Which versions are affected by GHSA-5847-rm3g-23mw?

2 open source packages ship an affected version, including openclaw.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.22 |
| `openclaw` | npm | All versions | 2026.2.22 |

## How do I fix GHSA-5847-rm3g-23mw?

Upgrade openclaw to 2026.2.22 or later.

## Is GHSA-5847-rm3g-23mw being exploited?

There is no known exploitation of GHSA-5847-rm3g-23mw in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5847-rm3g-23mw and fix it if it is affected.

What it is: GHSA-5847-rm3g-23mw is a vulnerability in openclaw, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5847-rm3g-23mw in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.22
- openclaw (npm): affected all versions; fixed in 2026.2.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5847-rm3g-23mw/ (Markdown: https://insights.sbomify.com/GHSA-5847-rm3g-23mw/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5847-rm3g-23mw

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5847-rm3g-23mw/
Summaries are generated and may contain mistakes; the official description above is the record.
