# GHSA-58q2-9x27-h2jm: solspace/craft-freeform Has a DoS Vulnerability

> Unauthenticated attackers can crash Craft CMS servers by sending large data URIs via the Freeform plugin's vulnerable Axios dependency.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026

## What is GHSA-58q2-9x27-h2jm?

GHSA-58q2-9x27-h2jm is a denial of service vulnerability in solspace/craft-freeform, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
Freeform plugin v4.1.29 uses vulnerable Axios ^1.7.7 allowing unauthenticated attackers to crash servers via malicious data: URIs causing memory exhaustion (CVE-2025-58754).

Freeform version: 4.1.29
Craft CMS version: 4.16.8

### Impact
When Axios runs on Node.js and is given a URL with the `data:` scheme, it does not perform HTTP. Instead, its Node http adapter decodes the entire payload into memory (`Buffer`/`Blob`) and returns a synthetic 200 response. This path ignores `maxContentLength` / `maxBodyLength` (which only protect HTTP responses), so an attacker can supply a very large `data:` URI and cause the process to allocate unbounded memory and crash (DoS), even if the caller requested `responseType: 'stream'`.

https://github.com/axios/axios/security/advisories/GHSA-4hjh-wcwx-xvwj
https://github.com/axios/axios/pull/7011
https://github.com/axios/axios/commit/945435fc51467303768202250debb8d4ae892593
https://github.com/axios/axios/releases/tag/v1.12.0

## Which versions are affected by GHSA-58q2-9x27-h2jm?

2 open source packages ship an affected version, including solspace/craft-freeform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `solspace/craft-freeform` | Packagist | All versions | 4.1.30 |
| `solspace/craft-freeform` | Packagist | All versions | 4.1.30 |

## How do I fix GHSA-58q2-9x27-h2jm?

Upgrade solspace/craft-freeform to 4.1.30 or later.

## Is GHSA-58q2-9x27-h2jm being exploited?

There is no known exploitation of GHSA-58q2-9x27-h2jm in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-58q2-9x27-h2jm and fix it if it is affected.

What it is: GHSA-58q2-9x27-h2jm is a denial of service vulnerability in solspace/craft-freeform, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-58q2-9x27-h2jm in the wild and no public exploit code.

Affected packages and fixed versions:
- solspace/craft-freeform (Packagist): affected all versions; fixed in 4.1.30
- solspace/craft-freeform (Packagist): affected all versions; fixed in 4.1.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-58q2-9x27-h2jm/ (Markdown: https://insights.sbomify.com/GHSA-58q2-9x27-h2jm/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-58q2-9x27-h2jm

---
From sbomify Insights: https://insights.sbomify.com/GHSA-58q2-9x27-h2jm/
Summaries are generated and may contain mistakes; the official description above is the record.
