{"answers":{"affected":"2 open source packages ship an affected version, including @asymmetric-effort/specifyjs.","exploited":"There is no known exploitation of GHSA-5c7w-4wm3-85vw in the wild and no public exploit code.","fix":"Upgrade @asymmetric-effort/specifyjs to 0.2.136 or later.","what":"GHSA-5c7w-4wm3-85vw is a code injection vulnerability in @asymmetric-effort/specifyjs, published on 2 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5c7w-4wm3-85vw and fix it if it is affected.\n\nWhat it is: GHSA-5c7w-4wm3-85vw is a code injection vulnerability in @asymmetric-effort/specifyjs, published on 2 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5c7w-4wm3-85vw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136\n- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5c7w-4wm3-85vw/ (Markdown: https://insights.sbomify.com/GHSA-5c7w-4wm3-85vw/index.md)","id":"GHSA-5c7w-4wm3-85vw","markdown":"https://insights.sbomify.com/GHSA-5c7w-4wm3-85vw/index.md","name":"GHSA-5c7w-4wm3-85vw","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL client library","requires_auth":"none","summary":"An attacker can inject GraphQL metacharacters via interpolated values in the gql tag, potentially executing arbitrary queries or accessing data.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Finding\n\n**Location**: `core/src/client/graphql.ts:66-80`\n\nThe `gql` template tag function warned about interpolated values containing GraphQL metacharacters (`{}():`) but still concatenated them into the query string, enabling potential GraphQL injection.\n\n## Status\n\n**Fixed in v0.2.136** — The `gql` function now throws an error when metacharacters are detected in interpolated values, forcing developers to use the `variables` parameter.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"@asymmetric-effort/specifyjs: GraphQL gql tag allows metacharacter injection","id":"GHSA-5c7w-4wm3-85vw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.2.136"],"introduced":["0"],"last_affected":[],"package":"@asymmetric-effort/specifyjs","purl":null,"source":"GHSA-5c7w-4wm3-85vw"},{"ecosystem":"npm","fixed":["0.2.136"],"introduced":["0"],"last_affected":[],"package":"@asymmetric-effort/specifyjs","purl":"pkg:npm/%40asymmetric-effort/specifyjs","source":"GHSA-5c7w-4wm3-85vw"}],"products":null,"published":"2026-07-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can inject GraphQL metacharacters via interpolated values in the gql tag, potentially executing arbitrary queries or accessing data.","url":"https://insights.sbomify.com/GHSA-5c7w-4wm3-85vw/"}