GHSA-5cpq-8wj7-hf2v Vulnerable OpenSSL included in cryptography wheels
The cryptography library bundles a vulnerable OpenSSL version, requiring users to upgrade to a patched release to mitigate underlying OpenSSL security flaws.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-5cpq-8wj7-hf2v?
GHSA-5cpq-8wj7-hf2v is a vulnerability in cryptography, published on 2 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.5-40.0.2 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://www.openssl.org/news/secadv/20230530.txt.
If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Which versions are affected by GHSA-5cpq-8wj7-hf2v?
2 open source packages ship an affected version, including cryptography.
| Package | Affected | Fixed in |
|---|---|---|
cryptography PyPI | From 0.5 | 41.0.0 |
cryptography PyPI | From 0.5 | 41.0.0 |
How do I fix GHSA-5cpq-8wj7-hf2v?
Upgrade cryptography to 41.0.0 or later.
Is GHSA-5cpq-8wj7-hf2v being exploited?
There is no known exploitation of GHSA-5cpq-8wj7-hf2v in the wild and no public exploit code.