{"answers":{"affected":"2 open source packages ship an affected version, including cryptography.","exploited":"There is no known exploitation of GHSA-5cpq-8wj7-hf2v in the wild and no public exploit code.","fix":"Upgrade cryptography to 41.0.0 or later.","what":"GHSA-5cpq-8wj7-hf2v is a vulnerability in cryptography, published on 2 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-5cpq-8wj7-hf2v and fix it if it is affected.\n\nWhat it is: GHSA-5cpq-8wj7-hf2v is a vulnerability in cryptography, published on 2 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-5cpq-8wj7-hf2v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cryptography (PyPI): affected from 0.5; fixed in 41.0.0\n- cryptography (PyPI): affected from 0.5; fixed in 41.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-5cpq-8wj7-hf2v/ (Markdown: https://insights.sbomify.com/GHSA-5cpq-8wj7-hf2v/index.md)","id":"GHSA-5cpq-8wj7-hf2v","markdown":"https://insights.sbomify.com/GHSA-5cpq-8wj7-hf2v/index.md","name":"GHSA-5cpq-8wj7-hf2v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"The cryptography library bundles a vulnerable OpenSSL version, requiring users to upgrade to a patched release to mitigate underlying OpenSSL security flaws.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.5-40.0.2 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://www.openssl.org/news/secadv/20230530.txt.\n\nIf you are building cryptography source (\"sdist\") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Vulnerable OpenSSL included in cryptography wheels","id":"GHSA-5cpq-8wj7-hf2v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["41.0.0"],"introduced":["0.5"],"last_affected":[],"package":"cryptography","purl":null,"source":"GHSA-5cpq-8wj7-hf2v"},{"ecosystem":"PyPI","fixed":["41.0.0"],"introduced":["0.5"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"GHSA-5cpq-8wj7-hf2v"}],"products":null,"published":"2023-06-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The cryptography library bundles a vulnerable OpenSSL version, requiring users to upgrade to a patched release to mitigate underlying OpenSSL security flaws.","url":"https://insights.sbomify.com/GHSA-5cpq-8wj7-hf2v/"}