# GHSA-5cpq-8wj7-hf2v: Vulnerable OpenSSL included in cryptography wheels

> The cryptography library bundles a vulnerable OpenSSL version, requiring users to upgrade to a patched release to mitigate underlying OpenSSL security flaws.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2023

## What is GHSA-5cpq-8wj7-hf2v?

GHSA-5cpq-8wj7-hf2v is a vulnerability in cryptography, published on 2 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.5-40.0.2 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://www.openssl.org/news/secadv/20230530.txt.

If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

## Which versions are affected by GHSA-5cpq-8wj7-hf2v?

2 open source packages ship an affected version, including cryptography.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | From 0.5 | 41.0.0 |
| `cryptography` | PyPI | From 0.5 | 41.0.0 |

## How do I fix GHSA-5cpq-8wj7-hf2v?

Upgrade cryptography to 41.0.0 or later.

## Is GHSA-5cpq-8wj7-hf2v being exploited?

There is no known exploitation of GHSA-5cpq-8wj7-hf2v in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-5cpq-8wj7-hf2v and fix it if it is affected.

What it is: GHSA-5cpq-8wj7-hf2v is a vulnerability in cryptography, published on 2 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-5cpq-8wj7-hf2v in the wild and no public exploit code.

Affected packages and fixed versions:
- cryptography (PyPI): affected from 0.5; fixed in 41.0.0
- cryptography (PyPI): affected from 0.5; fixed in 41.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-5cpq-8wj7-hf2v/ (Markdown: https://insights.sbomify.com/GHSA-5cpq-8wj7-hf2v/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-5cpq-8wj7-hf2v

---
From sbomify Insights: https://insights.sbomify.com/GHSA-5cpq-8wj7-hf2v/
Summaries are generated and may contain mistakes; the official description above is the record.
